An error occurred. (Error code: 9) (Extra code: 0)

Brass Contributor

Hi All 


I tried to update my EDGE, and got error as picture below. Could you help me how to fix it? I am using EDGE on Mac




43 Replies

If you have a new Mac or one that has never had Edge installed, installing Edge should proceed without any issues or errors.


However, if you do encounter an error, it's likely due to an incorrect login item. @mjj792msncom suggested unchecking this login item as a solution, but many, including myself (I succeeded once), have found this method ineffective. This Microsoft Corporation login item can be located in /Library/LaunchDaemons/. Be cautious: if you delete these items, you won't be able to retrieve them. The primary issue is that even after fully uninstalling Edge, this login item remains outdated, resulting in the error code: 9.


I appreciate your explanation. However, it appears that this information mainly highlights that the software is malfunctioning and requires attention from Microsoft.

As for my second point, and as you correctly pointed out, even after clearing the LaunchDaemons and ensuring that no files remain, if I reinstall Edge by downloading it from scratch, why does the error recur?

I took the step of removing Edge using AppCleaner, which should have removed all associated files including the Edge file in /Library/LaunchDaemons/.

I tested on both my new Mac and a Mac VM; both successfully downloaded the updated login item located in /Library/LaunchDaemons/.

However, if you merely uninstall Edge, it won't allow the updated login item in /Library/LaunchDaemons/ to be downloaded. Even when using AppCleaner, Microsoft doesn't recognize it as a clean environment. The determining factor is the Microsoft keychain. If you haven't deleted it, Edge will log in automatically without requiring you to enter credentials.

From my tests (conducted three times), when macOS is brand new and Edge has never been installed, the new Edge updates as expected. This is because it can fetch the updated login items from /Library/LaunchDaemons/. Furthermore, I found that even on a brand-new macOS, if you remove login items from /Library/LaunchDaemons/, you can't retrieve them again.

I believe this is because one of Microsoft's servers is down, preventing us from smoothly updating from our old login item to the new one.
I also find this very strange. No matter how you delete Edge, the 'login item' will never automatically download to your computer. However, on a Mac that has never had Edge installed, the 'login item' can be downloaded normally.
best response confirmed by daibt (Brass Contributor)

@CyrilYu run these commands would resolve the problem

sudo rm -rfv /Library/LaunchDaemons/*
sudo "/Applications/Microsoft Edge Framework.framework/Versions/118.0.2088.46/Helpers/" --install --system --v=2


then restart edge browser, open `edge://settings/help`, problem should resolved


(found solution after extract MicrosoftEdge-118.0.2088.46.pkg and read scripts/postinstall)


While it may appear straightforward, I followed these steps, but unfortunately, they did not resolve the issue. Let me outline the actions I took:


1 used AppCleaner to completely uninstall Microsoft Edge.
2 then downloaded Microsoft Edge directly from the official Microsoft website.
3 manually checked the LaunchDaemons folder to ensure there were no remaining Edge files.


Finally, I executed the installation process for the Edge browser.
I want to emphasise that I confirmed the absence of the mentioned file in the folder and executed the second command as suggested."



Here is after running the commandHere is after running the commandStill getting the errorStill getting the error


@Feejus  I tried in my mac VM, it works!!!

Thank you, it worked for me!!! How do you get this solution? I mean how do you find it on that pkg file?
I would greatly appreciate it if you could guide me on the steps I should take differently. I acknowledge that this solution has worked for some, as you've demonstrated, but it doesn't guarantee success for everyone. I followed the steps to uninstall it, and now my LaunchDaemons no longer contain any "Edge" files. I do have other Microsoft applications installed, such as OneDrive and Office, and they have "Login" items files.

@yeliex I can’t read your command. Can you please give complete command. The picture yo7 posted is truncated and I can’t see all of them. Thank for information

Thank you very much! This fixed my issue.

Two things that people might neglect and which may cause this not to work for them:


  1. I am using a custom terminal, iTerm2. By default, the security settings do not allow non-Apple apps to change applications on the system. To enable this, one would need to allow "App Management" for the custom terminal (and restart the terminal). If you're using a custom terminal, without this change, it won't work!
  2. I almost gave up while waiting! Don't give up. The second command takes its time.

@yeliex, great job! Thank you once again!

That solution didn't work for me at first, but after I followed your steps it finally worked! Thanks for your reminder!
It's not a picture, it's code snippet. Select it all, and copy. Here it is, but not nicely formatted:

sudo rm -rfv /Library/LaunchDaemons/*
sudo "/Applications/Microsoft Edge Framework.framework/Versions/118.0.2088.46/Helpers/" --install --system --v=2

@Feejus unnecessary to uninstall app, just open ``, copy and past my command, and enter password when required.


@CyrilYu as previous replies by others, I found it may relate to LaunchDaemons of edge. most app would update the daemon scripts when app launches, but edge seems only do that when app install, so I extracted install package and read scripts. The mostly possible reason of the bug is The not updated in `/Library/Microsoft/EdgeUpdater` in some reason. no time to research further, edge dev team should do this, not me

besides, the signal of commands run success is it finally print exit code 0, the commands call edge updater to reinstall it self to Mac system

 Hey everyone, I've discovered an alternative solution to the problem. As I mentioned earlier, the issue stems from the login item. While @yeliex's method is certainly effective, I've found another approach.

Instead of simply uninstalling, completely remove Microsoft Edge from your Mac. By "completely", I mean ensuring that no trace of any Microsoft Edge file remains on your system. I utilized the Spotlight search to locate and delete every associated Edge file. Once I completed this, I restarted my Mac, reinstalled Edge, and noticed that the login item it automatically downloaded resolved the issue.


It seems that merely using software like AppCleaner isn't thorough enough. Manually searching for and eliminating any lingering Edge files is essential.




I'm proud of myself because I was the first to notice that the problem arose in /Library/LaunchDaemons/. I tested with a virtual machine and found that new machines do not have the issue of login items failing to download. So, I believe the problem is that the new Edge installer doesn't recognize if your machine is brand new. Therefore, as long as you truly remove all the issues with Edge and download Edge from the official website, the problem will be easily resolved.

I just successfully tried it on my main machine. I carefully examined all files containing 'edge', meticulously deleted the files truly belonging to the MS Edge browser, and after restarting and installing Edge, all the problems disappeared. It's perfect.
There is n9 Mach in the first command. After I run the second command, then restart Edge. The problem is solved. Thank for information and fix
It works for me