Always getting this error when trying to update edge canary

Copper Contributor
7 Replies
I've tried to reinstall Edge Canary, still gives me the same error after 1-2 days

Hey there @xavieredouard! The team is investigating this and has a few questions for you if you don't mind providing the additional info. If you're willing to provide the extra info, please send me a private message with this instead of posting to the thread!


  1. Could you open and run the following command and paste the output? The command is: ls -la $HOME/Library/LaunchAgents
  2. Could you send us a copy of the logs at $HOME/Library/Application Support/Microsoft/EdgeUpdater/updater.log?
  3. Could you open and run the following command and paste the output? You will need to fill the version number with the version you have at the {VersionNumber} location in the command below. An example version number would be 95.0.1015.0. The command is: file $HOME/Library/Microsoft/EdgeUpdater/{VersionNumber}/

Any additional information should be really helpful for us to diagnose the issue and make the updater better for everyone, thank you so much!


Alex Rowell (she/her)
Community Manager - Microsoft Edge
Discuss Stable features and issues on the forums, join us on Twitter, or join the communities over on Reddit in r/MicrosoftEdge or r/edge

Thank you! I'll get this to the team and follow up with any questions.
Hey there! The team asked me to confirm if you're still consistently seeing this error, and if you've recently re-installed the browser (you do not need to do so now, this is based on what they're seeing in the log file you provided!)

Hi Alex, 


The issue came back, i'm now on Edge Canary version 98.0.1097.0 on MacOS Macbook Air M1 2020. Waiting to hear from you for help to resolve this issue. @Alexandra-R 

I'm also seeing the same error. I tried reinstalling and the error comes back a day or two later. If anyone has suggestions, please let me know. Thanks so much!