Address bar steals focus

Occasional Contributor



Edge has been working very well for a long time. However, I found recently that when you open a new tab, the focus is not on the webpage but still on the address bar.

(Note that InPrivate window does not have this issue.)




Version 81.0.416.72 (Official build) (64-bit)

Version 84.0.522.20 (Official build) beta (64-bit) (Edited on 6/16/2020)

17 Replies
Yes! This issue is incredibly infuriating. It has carried over from Insider into Stable. I hope the devs take notice of it.

@yzhang90 We appreciate you reporting this and making that helpful GIF. I have two questions for you:


  1. Of the fours build channels (Stable, Beta, Dev, and Canary) which one(s) are you seeing this in?
  2. If you haven't yet, can you please submit feedback for this? And if you'd like to make sure it gets to the correct team ASAP, feel free to DM me and I can give you a code to include in the description.

Fawkes (they/them)
Project & Community Manager - Microsoft Edge

@Deleted Thanks for the reply.


1. I'm using the stable build (I think) as I don't see any badge (like `beta`) on the Edge icon.

   (Version 81.0.416.72)

2. I'd like to but I'm not sure where I should submit the feedback. That's why I posted it here :grinning_face_with_sweat:.

@yzhang90 it was fixed in canary version

Happy to hear that

@yzhang90 Thanks for the info! Replying to your DM.


Fawkes (they/them)
Project & Community Manager - Microsoft Edge

I'm still having this exact problem, any possible solutions?

Here's my Edge builds: 83.0.478.54(stable) and 85.0.552.0(canary).
are you using omnibox setting in edge://flags

if so, set them in default

@TrueGame Thanks for your quick reply!

I got this problem on a fresh new installation, so no flags is set yet(just checked that all omnibox-related flags are set default).

Still no luck after re-installing them both.

Still experiencing this issue on Stable 83.0.478.56. Hope to see this solved ASAP.

A simple workaround for macOS: <cmd+,> to open preference tab, then <cmd+w> to close it, focus is back to page after that.

Hello~~~~~!! Still having this issue in stable build 83.0.478.58.

God this issue is annoying as hell, dude I have to switch back to chrome.


Still having this issue in stable build 83.0.478.58.

God this issue is annoying as hell, it's forcing people switch back to, you know :(


I think this is a change which has come from upstream Chromium because the same behaviour is also seen in the Chromium browser (Developer Build) version 86.0.4189.0 and in Google Chrome Stable Channel also.

@yzhang90 @TheShaunSaw @JimmyLiu @Wade_Middleton @TrueGame @RoccoW 


Thank you all for weighing in on what you're seeing. Thanks to your feedback, our Searchbar team is investigating this issue! We'll let you know if they have any findings to share.


As our team looks into this, they may need more diagnostic info. So, if you're still seeing this behavior and would like to help us troubleshoot, feel free to let us know in the comments below.


Fawkes (they/them)
Program Manager & Community Manager - Microsoft Edge

@Deleted The issue can only be replicated with Search on new tabs uses search box or address bar set to Address bar. You may or may not need a custom search engine set as default (I have not yet tested).

best response

Hey folks, I'm a dev from the Edge Address Bar team. I wanted to give a hearty Thank You for the invaluable information. Because of that we were able to deploy the fix yesterday. Since this was a server-side change, this fix should be live now.


Thanks again!