A file download problem in Edge Version 84.0.522.44 (official build) beta (32-Bit) for Windows 7

Occasional Contributor

Today I tried to download the latest version of a software called "Capslock+", the size of the executable file is 1.20MB so the download process finished in a second. But when the downloaded data was processing, the whole browser just crashed and the file can't be opened. I tried a few more times but the problem keeps showing up. I tried to use the standard Google Chrome Version 84.0.4147.89 to download this program and everything is just fine, the downloaded file is also able to open. Then I download a different executable file using the Edge Beta from another website and the whole download process ended perfectly. Is this problem only happens on my device? (Not native English speaker btw.)

1 Reply


Hi there, you are welcome to the Microsoft Edge Insider Community Hub!


I would recommend you to also send feedback about this issue through the in-app feedback tool in Microsoft Edge (Alt+Shift+I) with the diagnostics attached in order to help the Microsoft Edge dev team to resolve your issue as soon as possible.