A few quirks with Edge

%3CLINGO-SUB%20id%3D%22lingo-sub-1196100%22%20slang%3D%22en-US%22%3EA%20few%20quirks%20with%20Edge%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1196100%22%20slang%3D%22en-US%22%3E%3CP%3EFirst%20of%20all%20the%20Chromium%20Edge%20needs%20to%20fix%20the%20%5BF6%5D%20operation.%26nbsp%3B%20My%20version%20just%20updated%20from%2080%20to%2081%2C%20but%20still%20when%20I%20press%20%5BF6%5D%20it%20highlights%20the%20page%20tab.%26nbsp%3B%20A%20second%20press%20will%20move%20the%20focus%20to%20the%20address%2Fsearch%20bar%2C%20but%20that%20should%20be%20what%20happens%20when%20I%20first%20press%20%5BF6%5D.%26nbsp%3B%20Other%20Chromium%20based%20browsers%20work%20this%20way%20and%20most%20non-chromium%20browsers%20too.%3C%2FP%3E%3CP%3ESecondly%20why%20can't%20Chromium%20Edge%20see%20or%20use%20any%20of%20my%20printers%3F%26nbsp%3B%20I%20know%20I%20can%20print%20with%20%5BCtrl%5D%20%7BShift%5D%20%5BP%5D%20using%20the%20system%20print%20dialog%2C%20but%20why%20isn't%20Chromium%20Edge%20able%20to%20even%20acknowledge%20that%20I%20have%20printers%20available%20in%20its%20native%20print%20UI%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1196303%22%20slang%3D%22en-US%22%3ERe%3A%20A%20few%20quirks%20with%20Edge%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1196303%22%20slang%3D%22en-US%22%3E%3CP%3EHi%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F568612%22%20target%3D%22_blank%22%3E%40Jefronty%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eyour%20first%20issue%20with%20F6%20is%20also%20happening%20on%20Edge%20canary%2C%20just%20tested%20it%20right%20now%3CBR%20%2F%3EVersion%2082.0.436.0%20(Official%20build)%20canary%20(64-bit)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eabout%20printers%2C%20by%20native%20print%20UI%2C%20are%20you%20referring%20to%20this%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20image-alt%3D%22fdsfds.png%22%20style%3D%22width%3A%20365px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F173634i36E1A28851D05B98%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22fdsfds.png%22%20alt%3D%22fdsfds.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ealso%20do%20you%20have%20the%20same%20missing%20printers%20problem%20in%20Chrome%20(that%20is%20If%20you%20used%20Chrome%20before)%3C%2FP%3E%3CP%3Eand%20what%20is%20your%20operation%20system%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

First of all the Chromium Edge needs to fix the [F6] operation.  My version just updated from 80 to 81, but still when I press [F6] it highlights the page tab.  A second press will move the focus to the address/search bar, but that should be what happens when I first press [F6].  Other Chromium based browsers work this way and most non-chromium browsers too.

Secondly why can't Chromium Edge see or use any of my printers?  I know I can print with [Ctrl] {Shift] [P] using the system print dialog, but why isn't Chromium Edge able to even acknowledge that I have printers available in its native print UI?

9 Replies
Highlighted

Hi@Jefronty 

 

your first issue with F6 is also happening on Edge canary, just tested it right now
Version 82.0.436.0 (Official build) canary (64-bit)

 

about printers, by native print UI, are you referring to this?

 

fdsfds.png

 

also do you have the same missing printers problem in Chrome (that is If you used Chrome before)

and what is your operation system?

Highlighted

@HotCakeX yes, by native print UI I mean the default Chromium UI for print jobs which includes a preview.  Chrome and other Chromium based browsers and apps that I've used have full access to all of my computer's installed printers.  In Chromium Edge there are no printers listed and if I attempt to add a printer from either the print dialog or the browser settings it just opens the computer's list of printers (Win7: Control Panel\Printers, or Win10: Settings > Devices > Printers & Scanners) from the list of printers I've tried a double click on a printer, it just opens the printer's queue; I've also tried dragging a printer icon onto the browser window, which accomplishes nothing.

chromium-edge-print.png

Highlighted
Oh I see, what is your Windows 10 build number?
Highlighted

@HotCakeX 19041.84

Highlighted

@Jefronty, I'm having the same problem. Did this ever resolve? Or did you ever find a fix?

Highlighted

@impersonaljesus no, F6 still highlights the tab on first press and my only option from the default print dialogue is 'Save as PDF' despite having multiple printers available and installed on my computer.  I assume [Shift] [Ctrl] [P] or clicking "print using system dialog" from within the Chromium print dialog would work, but I don't remember whether I've tried that.

Highlighted

@Jefronty 

 

The F6 bug also existed in Chrome/Chromium around the time when Edge was forked from it.  Chrome quickly fixed the bug, but Edge is still using the broken behaviour.

 

That's an explanation of why the bug exists.  But I don't know whether the Edge team knows about it or have decided to not fix it.

Highlighted
You may wish to make a habit of using Ctrl+L instead if it’s just about getting to the address bar quickly. You can also use Ctrl+E or Ctrl+K to search with your default search engine.

I realise this isn’t a solution for the issue you are having, but Ctrl+L is much more convenient as a touch typist (ie you do not have to leave the home row; it is a good habit to get into).
Highlighted
I've been trying to switch to using ctrl+L in the last few months, but 15 years of using a shortcut is hard to unlearn. When my hands aren't on the keyboard at the time, striking F6 with one hand is easier than pressing 2 keys. I have found, like you say, that ctrl+L is easier most of the time.