84.0.481 just appeared, but it doesn't fix the update error first seen in 84.0.480

%3CLINGO-SUB%20id%3D%22lingo-sub-1299112%22%20slang%3D%22en-US%22%3ERe%3A%2084.0.481%20just%20appeared%2C%20but%20it%20doesn't%20fix%20the%20update%20error%20first%20seen%20in%2084.0.480%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1299112%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F451443%22%20target%3D%22_blank%22%3E%40geoffarnold%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20uninstalled%20.480%20and%20reinstalled%20and%20.481%3C%2FP%3E%3CP%3Ehas%20the%20same%20issue.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1299408%22%20slang%3D%22en-US%22%3ERe%3A%2084.0.481%20just%20appeared%2C%20but%20it%20doesn't%20fix%20the%20update%20error%20first%20seen%20in%2084.0.480%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1299408%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%20class%3D%22c01191%22%3EI%20also%20have%20the%20error%20code%203%3A0x80004002.%20Doesn't%20know%20what%20it%20means.%20The%20red%20circle%20with%20the%20%3CSPAN%20class%3D%22tlid-translation%20translation%22%3E%3CSPAN%20class%3D%22%22%3Eexclamation%20mark%3C%2FSPAN%3E%3C%2FSPAN%3E%20is%20also%20present%20since%20three%20or%20four%20days%20in%20Microsoft%20Edge%20Canary.%20Please%20team%2Cyou%20must%20fix%20this%20bug.%20%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1299069%22%20slang%3D%22en-US%22%3E84.0.481%20just%20appeared%2C%20but%20it%20doesn't%20fix%20the%20update%20error%20first%20seen%20in%2084.0.480%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1299069%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%20class%3D%22c01191%22%3EEdge%20Canary%20just%20invited%20me%20to%20restart%20Edge%20to%20update%20it.%20Of%20course%20the%20update%20problem%20that%20emerged%20recently%20means%20that%20you%20can't%20use%20the%20Setting-%26gt%3BAbout-%26gt%3BCheck%20for%20update%20process.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22c01191%22%3EHowever%20this%20update%20also%20failed.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22c01191%22%3EAn%20error%20occurred%20while%20checking%20for%20updates%3A%20We%20couldn't%20create%20that%20component%20(error%20code%203%3A%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3CA%20href%3D%22https%3A%2F%2Fgo.microsoft.com%2Ffwlink%2F%3Flinkid%3D2068169%26amp%3B0x80040154%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3E0x80040154%3C%2FA%3E).%3C%2FSPAN%3E%3CSPAN%3E%3CA%20href%3D%22https%3A%2F%2Fgo.microsoft.com%2Ffwlink%2F%3Flinkid%3D2068169%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3ELearn%20more%26nbsp%3B%3C%2FA%3E%3C%2FSPAN%3E%3CSPAN%20class%3D%22c01192%22%3EVersion%2084.0.481.0%20(Official%20build)%20canary%20(64-bit)%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22c01192%22%3EUPDATE%3A%20As%20of%20485%20this%20is%20fixed.%20I'm%20now%20on%20487.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1299517%22%20slang%3D%22en-US%22%3ERe%3A%2084.0.481%20just%20appeared%2C%20but%20it%20doesn't%20fix%20the%20update%20error%20first%20seen%20in%2084.0.480%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1299517%22%20slang%3D%22en-US%22%3E%3CP%3EWe're%20all%20experiencing%20this%2C%20it's%20natural%20for%20Canary%20though%2C%20it%20is%20supposed%20to%20be%20less%20stable%20than%20Dev%20and%20other%20channels%20respectively.%20now%20it%20feels%20more%20like%20it%20%3A)%3C%2Fimg%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIt%20is%20fixed%20since%20Microsoft%20Edge%20%3CSPAN%3EVersion%2084.0.485.0%20(Official%20build)%20canary%20(64-bit)%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

Edge Canary just invited me to restart Edge to update it. Of course the update problem that emerged recently means that you can't use the Setting->About->Check for update process.

 

However this update also failed.

 

An error occurred while checking for updates: We couldn't create that component (error code 3: 0x80040154).Learn more Version 84.0.481.0 (Official build) canary (64-bit)

 

UPDATE: As of 485 this is fixed. I'm now on 487.

3 Replies
Highlighted

@geoffarnold 

I uninstalled .480 and reinstalled and .481

has the same issue.

Highlighted

I also have the error code 3:0x80004002. Doesn't know what it means. The red circle with the exclamation mark is also present since three or four days in Microsoft Edge Canary. Please team,you must fix this bug.

Highlighted

We're all experiencing this, it's natural for Canary though, it is supposed to be less stable than Dev and other channels respectively. now it feels more like it :)

 

It is fixed since Microsoft Edge Version 84.0.485.0 (Official build) canary (64-bit)