Home

3rd Party Web Application won't run in Edge Beta

%3CLINGO-SUB%20id%3D%22lingo-sub-999777%22%20slang%3D%22en-US%22%3E3rd%20Party%20Web%20Application%20won't%20run%20in%20Edge%20Beta%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-999777%22%20slang%3D%22en-US%22%3E%3CP%3EHaving%20just%20returned%20from%20Ignite%2C%20I%20was%20excited%20to%20learn%20about%20the%20new%20Edge%20beta%20and%20installed%20it.%20We%20were%20told%20that%20every%20site%20would%20work%20at%20least%20in%20%22internet%20explorer%20mode%22%20but%20one%20of%20our%203rd%20party%20vendor%20web-apps%20does%20not.%20It%20is%20from%20BST%20Global%20(bstglobal.com%2F).%20I%20runs%20fine%20in%20Internet%20Explorer%20but%20does%20not%20load%20in%20the%20new%20Edge%20and%20I%20don't%20see%20any%20indication%20that%20it's%20trying%20to%20run%20in%20IE%20mode%20(or%20if%20that%20is%20something%20I%20need%20to%20force%20it%20to%20do).%20I'm%20pretty%20certain%20it%20uses%20Active%20X%20controls.%20Is%20there%20some%20process%20I%20can%20work%20through%20to%20try%20and%20get%20it%20to%20run%20correctly%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-999822%22%20slang%3D%22en-US%22%3ERe%3A%203rd%20Party%20Web%20Application%20won't%20run%20in%20Edge%20Beta%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-999822%22%20slang%3D%22en-US%22%3EHi%2C%3CBR%20%2F%3Ehave%20you%20enabled%20Internet%20explorer%20mode%20in%20your%20environment%3F%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fdeployedge%2Fedge-ie-mode%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fdeployedge%2Fedge-ie-mode%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3EHow%20do%20I%20know%20if%20a%20site%20is%20loading%20in%20IE%20mode%3F%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fdeployedge%2Fedge-ie-mode%23frequently-asked-questions%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fdeployedge%2Fedge-ie-mode%23frequently-asked-questions%3C%2FA%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1000070%22%20slang%3D%22en-US%22%3ERe%3A%203rd%20Party%20Web%20Application%20won't%20run%20in%20Edge%20Beta%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1000070%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3BI%20have%20now.%20thanks.%20Waiting%20for%20GP%20to%20propagate%20to%20see%20if%20that%20worked.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1000269%22%20slang%3D%22en-US%22%3ERe%3A%203rd%20Party%20Web%20Application%20won't%20run%20in%20Edge%20Beta%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1000269%22%20slang%3D%22en-US%22%3EYou're%20welcome%2C%3CBR%20%2F%3Ein%20case%20it%20takes%20too%20long%2C%20run%20%22gpupdate%20%2Fforce%22%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1000330%22%20slang%3D%22en-US%22%3ERe%3A%203rd%20Party%20Web%20Application%20won't%20run%20in%20Edge%20Beta%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1000330%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3BI%20did%20and%20I%20can%20see%20the%20policies%20applied%3A%26nbsp%3B%3CA%20href%3D%22edge%3A%2F%2Fpolicy%2F%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Eedge%3A%2F%2Fpolicy%2F%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20thought%20I%20set%20everything%20correctly%20but%20it%20still%20doesn't%20seem%20to%20work.%3C%2FP%3E%3CDIV%20class%3D%22c0196%20c01116%20entry%22%3E%3CSPAN%20class%3D%22%22%3E%3CA%20title%3D%22Learn%20more%20about%20InternetExplorerIntegrationLevel%20policy%22%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2FDeployEdge%2Fmicrosoft-edge-policies%23internetexplorerintegrationlevel%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3EInternetExplorerIntegrationLevel%26nbsp%3B%26nbsp%3B%3C%2FA%3E%3C%2FSPAN%3E%3CSPAN%20class%3D%22c01119%22%3E1%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%20class%3D%22c0196%20c01116%20entry%22%3E%3CSPAN%20class%3D%22%22%3E%3CA%20title%3D%22Learn%20more%20about%20InternetExplorerIntegrationSiteList%20policy%22%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2FDeployEdge%2Fmicrosoft-edge-policies%23internetexplorerintegrationsitelist%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3EInternetExplorerIntegrationSiteList%26nbsp%3B%26nbsp%3B%3C%2FA%3E%3C%2FSPAN%3E%3CSPAN%20class%3D%22c01119%22%3E%5C%5Ccas-dc1%5CNETLOGON%5Ciesites.xml%3C%2FSPAN%3E%26nbsp%3B%26nbsp%3B%3C%2FDIV%3E%3CDIV%20class%3D%22c0196%20c01116%20entry%22%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%20class%3D%22c0196%20c01116%20entry%22%3E%3CSPAN%20class%3D%22c01119%22%3Eand%20this%20inside%20the%20XML%20doc%3A%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%20class%3D%22c0196%20c01116%20entry%22%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%20class%3D%22c0196%20c01116%20entry%22%3E%3CP%3E%3CSITE%20url%3D%22%26quot%3Bhttp%3A%2F%2Fcas-bst%2Fauroraweb%2F%26quot%3B%22%3E%3C%2FSITE%3E%3C%2FP%3E%3CP%3E%3COPEN-IN%20app%3D%22%26quot%3Btrue%26quot%3B%22%3EIE11%3C%2FOPEN-IN%3E%3C%2FP%3E%3CP%3E%3C%2FP%3E%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CP%3E%3C%2FP%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1000387%22%20slang%3D%22en-US%22%3ERe%3A%203rd%20Party%20Web%20Application%20won't%20run%20in%20Edge%20Beta%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1000387%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F427234%22%20target%3D%22_blank%22%3E%4010toes%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECan%20you%20try%20using%20the%20Enterprise%20mode%20site%20list%20manager%20to%20test%20it%3F%3C%2FP%3E%3CP%3E%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Finternet-explorer%2Fie11-deploy-guide%2Fuse-the-enterprise-mode-site-list-manager%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Finternet-explorer%2Fie11-deploy-guide%2Fuse-the-enterprise-mode-site-list-manager%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ethere%20needs%20to%20be%20a%20site-list%20version%20parameter%20in%20your%20.xml%20file%20too.%26nbsp%3B%3C%2FP%3E%3CP%3Ewhen%20I%20used%20it%2C%20the%20created%20xml%20file%20looked%20like%20this%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CPRE%20class%3D%22lia-code-sample%20language-markup%22%3E%3CCODE%3E%3CSITE-LIST%20version%3D%223%22%3E%0A%20%20%3CCREATED-BY%3E%0A%20%20%20%20%3CTOOL%3EEMIESiteListManager%3C%2FTOOL%3E%0A%20%20%20%20%3CVERSION%3E10.0.14357.1004%3C%2FVERSION%3E%0A%20%20%20%20%3CDATE-CREATED%3E09%2F30%2F2019%2008%3A56%3A15%3C%2FDATE-CREATED%3E%0A%20%20%3C%2FCREATED-BY%3E%0A%20%20%3CSITE%20url%3D%22bing.com%22%3E%0A%20%20%20%20%3CCOMPAT-MODE%3EDefault%3C%2FCOMPAT-MODE%3E%0A%20%20%20%20%3COPEN-IN%3EIE11%3C%2FOPEN-IN%3E%0A%20%20%3C%2FSITE%3E%0A%20%20%3CSITE%20url%3D%22necacom.net%22%3E%0A%20%20%20%20%3CCOMPAT-MODE%3EDefault%3C%2FCOMPAT-MODE%3E%0A%20%20%20%20%3COPEN-IN%3EIE11%3C%2FOPEN-IN%3E%0A%20%20%3C%2FSITE%3E%0A%3C%2FSITE-LIST%3E%3C%2FCODE%3E%3C%2FPRE%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1000452%22%20slang%3D%22en-US%22%3ERe%3A%203rd%20Party%20Web%20Application%20won't%20run%20in%20Edge%20Beta%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1000452%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3BI%20used%20the%20tool%2C%20but%20it%20said%20it%20couldn't%20connect%20to%20the%20URL.%20Could%20it%20be%20because%20it's%20not%20pointing%20to%20a%20full%20domain%20name%20(with%20a%20.com%20extension)%20as%20it's%20running%20on%20an%20internal%20server%3F%20We%20point%20IE%20to%20http%3A%2F%2Fcas-bst%20and%20the%20site%20loads.%20I%20did%20modify%20the%20XML%20to%20include%20the%20revisions%20you%20suggested.%20Still%20no%20luck.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20also%20changed%20the%20site%20to%20yahoo.com%20to%20see%20if%20I%20could%20verify%20at%20least%20that%20site%20was%20working%2C%20but%20it%20also%20does%20not%20appear%20in%20IE%20mode%20either.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1000510%22%20slang%3D%22en-US%22%3ERe%3A%203rd%20Party%20Web%20Application%20won't%20run%20in%20Edge%20Beta%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1000510%22%20slang%3D%22en-US%22%3ETry%20configuring%20it%20to%20load%20all%20intranet%20sites%20in%20IE%20mode%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fdeployedge%2Fedge-ie-mode%23configure-all-intranet-sites%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fdeployedge%2Fedge-ie-mode%23configure-all-intranet-sites%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3Ei%20can't%20tell%20exactly%20what%20is%20not%20working%2C%20if%20you%20see%20the%20policies%20you%20set%20in%3CBR%20%2F%3Eedge%3A%2F%2Fpolicy%2F%3CBR%20%2F%3Eand%20the%20sitelist.xml%20file%20is%20also%20visible%20in%20that%20page%20and%20you%20can%20see%20the%20contents%2C%20then%20all%20should%20work.%3CBR%20%2F%3E%3CBR%20%2F%3Eunless%20you%20haven't%20enabled%20the%20other%20group%20policy%20required%20to%20enable%20IE%20mode%20for%20your%20Edge%3F%20that's%20the%20only%20thing%20i%20can%20think%20of.%3CBR%20%2F%3E%3CBR%20%2F%3Etry%20turning%20on%20IE%20mode%20using%20the%20flags%20instead%3A%3CBR%20%2F%3Eedge%3A%2F%2Fflags%2F%3CBR%20%2F%3Eenable%20these%3A%3CBR%20%2F%3E%3CBR%20%2F%3EEnable%20IE%20Integration%3CBR%20%2F%3EEnables%20integration%20with%20Internet%20Explorer%20%E2%80%93%20Windows%3CBR%20%2F%3E%23edge-internet-explorer-integration%3CBR%20%2F%3E%3CBR%20%2F%3E%3CBR%20%2F%3EEnable%20enhanced%20hang%20resistance%20for%20IE%20Integration%3CBR%20%2F%3EEnables%20enhanced%20hang%20resistance%20for%20Internet%20Explorer%20mode%20%E2%80%93%20Windows%3CBR%20%2F%3E%23edge-internet-explorer-integration-enhanced-hang-resistance%3CBR%20%2F%3E%3CBR%20%2F%3E%3CBR%20%2F%3EEnable%20IE%20window%20hang%20resistance%20for%20IE%20Integration%3CBR%20%2F%3EEnables%20resistance%20to%20Internet%20Explorer%20window%20hangs%20for%20Internet%20Explorer%20mode%20%E2%80%93%20Windows%3CBR%20%2F%3E%23edge-internet-explorer-integration-window-hang-resistance%3CBR%20%2F%3E%3CBR%20%2F%3E%3CBR%20%2F%3EEnable%20Delete%20Browsing%20History%20Support%20for%20Internet%20Explorer%20Integration%3CBR%20%2F%3EEnable%20Delete%20Browsing%20History%20for%20Internet%20Explorer%20Integration%20on%20settings%20page%2C%20and%20Delete%20Browsing%20History%20on%20Exit%20integration%20with%20Internet%20Explorer%20mode.%20%E2%80%93%20Windows%3CBR%20%2F%3E%23edge-internet-explorer-integration-delete-browsing-history%3CBR%20%2F%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1002038%22%20slang%3D%22en-US%22%3ERe%3A%203rd%20Party%20Web%20Application%20won't%20run%20in%20Edge%20Beta%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1002038%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3BSeem%20to%20be%20making%20a%20little%20progress.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20was%20able%20to%20get%20IE%20Mode%20working%20(tested%20by%20setting%20the%20XML%20file%20to%20load%20Yahoo.com%20in%20IE%20Mode).%20That%20worked.%20I%20then%20put%20the%20URL%20of%20the%20web-app%20back%20in%20to%20test.%20Now%2C%20when%20the%20site%20starts%20to%20load%2C%20I%20do%20see%20the%20IE%20Mode%20icon%20flash%20briefly%2C%20but%20then%20it%20disappears%20as%20it%20moves%20to%20loading%20the%20.asp%20page%20that%20loads%20the%20content.%20It%20never%20progresses%20beyond%20the%20logo%20screen.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1002050%22%20slang%3D%22en-US%22%3ERe%3A%203rd%20Party%20Web%20Application%20won't%20run%20in%20Edge%20Beta%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1002050%22%20slang%3D%22en-US%22%3Ealmost%20got%20it.%20I%20made%20a%20couple%20of%20changes%2C%20and%20if%20I%20manually%20type%20the%20final%20URL%20of%20the%20web-app%20instead%20of%20letting%20it%20route%20itself%20through%20landing%20pages%2C%20etc.%2C%20it%20loads.%20Thanks%20for%20the%20help.%20I%20should%20be%20able%20to%20lock%20it%20in%20from%20here.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1002519%22%20slang%3D%22en-US%22%3ERe%3A%203rd%20Party%20Web%20Application%20won't%20run%20in%20Edge%20Beta%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1002519%22%20slang%3D%22en-US%22%3EYou're%20welcome%2C%20happy%20to%20hear%20you%20got%20it%20working%20%3A)%3C%2Fimg%3E%3C%2FLINGO-BODY%3E
10toes
Occasional Contributor

Having just returned from Ignite, I was excited to learn about the new Edge beta and installed it. We were told that every site would work at least in "internet explorer mode" but one of our 3rd party vendor web-apps does not. It is from BST Global (bstglobal.com/). I runs fine in Internet Explorer but does not load in the new Edge and I don't see any indication that it's trying to run in IE mode (or if that is something I need to force it to do). I'm pretty certain it uses Active X controls. Is there some process I can work through to try and get it to run correctly?

10 Replies
Hi,
have you enabled Internet explorer mode in your environment?
https://docs.microsoft.com/en-us/deployedge/edge-ie-mode

How do I know if a site is loading in IE mode?
https://docs.microsoft.com/en-us/deployedge/edge-ie-mode#frequently-asked-questions

@HotCakeX I have now. thanks. Waiting for GP to propagate to see if that worked. 

You're welcome,
in case it takes too long, run "gpupdate /force"

@HotCakeX I did and I can see the policies applied: edge://policy/

 

I thought I set everything correctly but it still doesn't seem to work.

InternetExplorerIntegrationLevel  1
 
InternetExplorerIntegrationSiteList  \\cas-dc1\NETLOGON\iesites.xml  
 
and this inside the XML doc:
 

<site url="http://cas-bst/auroraweb/">

<open-in app="true">IE11</open-in>

</site>

@10toes 

 

Can you try using the Enterprise mode site list manager to test it?


https://docs.microsoft.com/en-us/internet-explorer/ie11-deploy-guide/use-the-enterprise-mode-site-li...

 

there needs to be a site-list version parameter in your .xml file too. 

when I used it, the created xml file looked like this:

 

<site-list version="3">
  <created-by>
    <tool>EMIESiteListManager</tool>
    <version>10.0.14357.1004</version>
    <date-created>09/30/2019 08:56:15</date-created>
  </created-by>
  <site url="bing.com">
    <compat-mode>Default</compat-mode>
    <open-in>IE11</open-in>
  </site>
  <site url="necacom.net">
    <compat-mode>Default</compat-mode>
    <open-in>IE11</open-in>
  </site>
</site-list>

@HotCakeX I used the tool, but it said it couldn't connect to the URL. Could it be because it's not pointing to a full domain name (with a .com extension) as it's running on an internal server? We point IE to http://cas-bst and the site loads. I did modify the XML to include the revisions you suggested. Still no luck.

 

I also changed the site to yahoo.com to see if I could verify at least that site was working, but it also does not appear in IE mode either.

Try configuring it to load all intranet sites in IE mode
https://docs.microsoft.com/en-us/deployedge/edge-ie-mode#configure-all-intranet-sites

i can't tell exactly what is not working, if you see the policies you set in
edge://policy/
and the sitelist.xml file is also visible in that page and you can see the contents, then all should work.

unless you haven't enabled the other group policy required to enable IE mode for your Edge? that's the only thing i can think of.

try turning on IE mode using the flags instead:
edge://flags/
enable these:

Enable IE Integration
Enables integration with Internet Explorer – Windows
#edge-internet-explorer-integration


Enable enhanced hang resistance for IE Integration
Enables enhanced hang resistance for Internet Explorer mode – Windows
#edge-internet-explorer-integration-enhanced-hang-resistance


Enable IE window hang resistance for IE Integration
Enables resistance to Internet Explorer window hangs for Internet Explorer mode – Windows
#edge-internet-explorer-integration-window-hang-resistance


Enable Delete Browsing History Support for Internet Explorer Integration
Enable Delete Browsing History for Internet Explorer Integration on settings page, and Delete Browsing History on Exit integration with Internet Explorer mode. – Windows
#edge-internet-explorer-integration-delete-browsing-history


@HotCakeX Seem to be making a little progress.

 

I was able to get IE Mode working (tested by setting the XML file to load Yahoo.com in IE Mode). That worked. I then put the URL of the web-app back in to test. Now, when the site starts to load, I do see the IE Mode icon flash briefly, but then it disappears as it moves to loading the .asp page that loads the content. It never progresses beyond the logo screen. 

almost got it. I made a couple of changes, and if I manually type the final URL of the web-app instead of letting it route itself through landing pages, etc., it loads. Thanks for the help. I should be able to lock it in from here.
You're welcome, happy to hear you got it working :)