107 beachball'n frequently?

Brass Contributor

Hi folks,


Anyone got a track on any issues in Edge 107.0.1418.56 that cause beachballing on macOS Ventura 13.0.1, M1 architecture? I can barely go a few minutes using sites like outlook.live.com and teams.microsoft.com without Edge hanging up with the beachball cursor and 100%-ish CPU shown in Activity Monitor. For whatever reason these are the only two sites - I've spent plenty of time on other sites with no such issue. Someone on Twitter mentioned something similar with Azure Portal - curious we have Microsoft websites in common on this.


For me, the action immediately prior to the hang isn't always the same, but in Outlook web it seems to be often responding to a prompt dialog (like the one when emptying the junk folder), or when viewing a message that has an attachment in the attachment preview pane. In Teams web, which I don't use a lot, it hung when adding a new channel, I think when using input field to name the channel. Feels like maybe it's focus/input related?


I've always had to resort to Force Quit. If anyone has suggested diagnostic steps I'm all ears, but don't want to bother if this is already known. Happy to try a 108/109 build if you think it's cured there. Chrome 107 appears to be OK on the same sites.

14 Replies

@Wade Dorrell 


Yes, this is happening to me in the same scenarios using Edge arm64 on macOS 12.6 with an M1 Pro chip.


Previewing attachments in Outlook and in the account menu in Teams.


Looks like a major bug.

Occurring in both 107.0.1418.56 and 107.0.1418.62

109.0.1518.5 also seems to be affected.

I'm finding I can reproduce it rather regularly by clicking an attachment in outlook.live.com such that the larger view of the email which includes preview pane opens up. Sometimes the attachment previews, but after a couple tries opening the same email/attachment it hangs up. Same scenario in Chrome, no sweat. Reproduces with something as simple as a JPG attachment.

Looks like this at the point it hangs:

Untitled 2.jpg

After trying the beta, dev, canary and old release build 107.0.1418.52. I decided to clear all cookies. It hasn't happened since :crossed_fingers:
And now it's happening again...

@Paul Bellamy  - i cleared cache and worked once and then stopped working. Safari is fine, but Edge is not. Can recreate on outlook.office.com/mail by previewing attachment or "Discard message" confirmation box.


It didn't start until I upgraded to Ventura.


Ventura 13.0.1

Version 107.0.1418.62 (Official build) (arm64)

@nmj22 I'm still on Monterey 12.6 to try and avoid these kind of show-stopper bugs... that hasn't worked out for me in this instance.

@Paul Bellamy - I uninstalled Edge and re-installed (you have to choose the Apple chip option) and the steps the recreate I had in the past now succeed.


This shouldn't be necessary, but uninstall of edge and re-install so far successful.

This issue didn't start happening until I went to Ventura.


Good luck!

It looks to me like this was possibly fixed in 108.0.1462.41 - this morning I hit the hang (on a confirmation dialog in Outlook web), came here to forum to check status, and upon seeing @nmj22's comment about reinstalling I checked for update under "About Microsoft Edge" first (did not uninstall/reinstall) and there was a new update from 107.0.1418.68 to 108.0.1462.41. My fairly reliable steps w/ Outlook web don't recreate the problem anymore on 1462.41. I'll check in in a few days.

Edit: My bad, not fixed in 108.0.1462.41. I've now had it beachball-hang twice now in 1462.41, once in Outlook web on a dialog there - hangs around Outook's dialogs have been par for the course with this issue - and once in Edge's own "Edit Favorite" dialog, when pressing the "Save" button, that's a new one for me and possibly not related?

@Wade Dorrell thanks! It looks like 1462.41 has resolved the issue for me as well. This is going to make my day a lot easier :)
@Wade Dorrell Spoke too soon. It's happening again.

@nmj22 What uninstall process did you follow?
For me, it's not. Still the same issue. Can't work on a few profiles currently.
Yeah I've reached the limit of my patience, and have been forced to switch to Chrome.

I was seeing similar hangs at some point after upgrading to Ventura. I think I first noticed it on Edge M106 or so.

I had a hunch that this related to accessibility support, since the last time (> 6 months ago) Edge was hanging a lot, I was testing out yabai, a window management tool that uses the macOS accessibility APIs: 

I ended up using Hammerspoon instead of yabai, but that also uses the macOS accessibility APIs, so I tried quitting Hammerspoon, and Edge seemed to stop crashing after. I went through a few Edge/Chrome updates that seemed to maybe fix or reintroduce the hang whenever Hammerspoon was running.

Last night I tried disabling accessibility support in Edge itself and that seemed to also fix the hangs.
See https://www.chromium.org/developers/design-documents/accessibility/

If you quit all Edge instances and run this in Terminal, it disables accessibility you quit all Edge instances again:


open /Applications/Microsoft\ Edge.app --args --disable-renderer-accessibility


Edge and Chrome both got new updates today on my Mac, and I can't repro the hang at all anymore even with accessibility enabled, so the actual bug might be finally fixed now...