Error while configuring Hybrid "Powershell failed to invoke 'Get-HybridMailflowDatacenterIPs' "

%3CLINGO-SUB%20id%3D%22lingo-sub-71782%22%20slang%3D%22en-US%22%3EError%20while%20configuring%20Hybrid%20%22Powershell%20failed%20to%20invoke%20'Get-HybridMailflowDatacenterIPs'%20%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-71782%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EGetting%20error%20while%20running%20Hybrid%20setup.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22PropertySheet%22%3E%3CSPAN%3EHWC0%20-%20Powershell%20failed%20to%20invoke%20'Get-HybridMailflowDatacenterIPs'%3A%20Parameter%20count%20mismatch.%20An%20unexpected%20error%20has%20occurred%20and%20a%20Watson%20dump%20is%20being%20generated%3A%20Parameter%20count%20mismatch.%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22PropertySheet%22%3E%3CSPAN%3E------------%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22PropertySheet%22%3E%3CSPAN%3E2017.05.22%2007%3A05%3A49.201%20*ERROR*%20%5BClient%3DUX%2C%20Functionality%3DRunWorkflow%2C%20Workflow%3DHybrid%2C%20Task%3DMailFlow%2C%20Phase%3DCheckPrerequisites%2C%20Thread%3D6%5D%20FINISH%20Time%3D12.8s%20Results%3DFAILED%20(Prerequisites%20NOT%20MET)%3CBR%20%2F%3E2017.05.22%2007%3A05%3A49.201%20*ERROR*%20%5BClient%3DUX%2C%20Functionality%3DRunWorkflow%2C%20Workflow%3DHybrid%2C%20Task%3DMailFlow%2C%20Thread%3D6%5D%20FINISH%20Time%3D12.8s%20Results%3DFAILED%3CBR%20%2F%3E2017.05.22%2007%3A05%3A49.216%20*ERROR*%20%5BClient%3DUX%2C%20Functionality%3DRunWorkflow%2C%20Workflow%3DHybrid%2C%20Thread%3D6%5D%20FINISH%20Time%3D23.8s%20Results%3DFAILED%3CBR%20%2F%3E2017.05.22%2007%3A05%3A49.216%20%5BClient%3DUX%2C%20Provider%3DOnPremises%2C%20Thread%3D6%5D%20Disposing%20Runspace.%3CBR%20%2F%3E2017.05.22%2007%3A05%3A49.216%20%5BClient%3DUX%2C%20Provider%3DTenant%2C%20Thread%3D6%5D%20Disposing%20Runspace.%3CBR%20%2F%3E2017.05.22%2007%3A05%3A49.451%20*ERROR*%20%5BClient%3DUX%2C%20Functionality%3DRunWorkflow%2C%20Thread%3D6%5D%20HCW0000%20PowerShell%20failed%20to%20invoke%20'Get-HybridMailflowDatacenterIPs'%3A%20Parameter%20count%20mismatch.%20An%20unexpected%20error%20has%20occurred%20and%20a%20Watson%20dump%20is%20being%20generated%3A%20Parameter%20count%20mismatch.%3CBR%20%2F%3E2017.05.22%2007%3A05%3A49.466%20WARNING%20%5BClient%3DUX%2C%20Functionality%3DRunWorkflow%2C%20Thread%3D6%5D%20HCW8055%20The%20Legacy%20Email%20Address%20Policy%20'domain'%20cannot%20be%20automatically%20updated%20and%20must%20be%20manually%20upgraded.%3CBR%20%2F%3E2017.05.22%2007%3A05%3A49.466%20WARNING%20%5BClient%3DUX%2C%20Functionality%3DRunWorkflow%2C%20Thread%3D6%5D%20HCW8057%20Office%20365%20was%20unable%20to%20communicate%20with%20your%20on-premises%20Autodiscover%20endpoint.%20This%20is%20typically%20due%20to%20incorrect%20DNS%20or%20firewall%20configuration.%20The%20Office%20365%20tenant%20is%20currently%20configured%20to%20use%20the%20following%20URL%20for%20Autodiscover%20queries%20from%20the%20Office%20365%20tenant%20to%20the%20on-premises%20organization%20-%20%3CA%20href%3D%22https%3A%2F%2Fautodiscover.domain.com%2Fautodiscover%2Fautodiscover.svc%2FWSSecurity%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fautodiscover.domain.com%2Fautodiscover%2Fautodiscover.svc%2FWSSecurity%3C%2FA%3E.%3CBR%20%2F%3E2017.05.22%2007%3A05%3A49.544%20%5BClient%3DUX%2C%20Thread%3D6%5D%20UX%20Time%3A%205%2F22%2F2017%2012%3A04%3A18%20PM%20%2B08%3A00%205%2F22%2F2017%203%3A05%3A49%20PM%20%2B08%3A00%2003%3A01%3A30.8978209%20182%3CBR%20%2F%3E%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22PropertySheet%22%3E%3CSPAN%3E------------------%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22PropertySheet%22%3E%3CSPAN%3EThanks%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-71782%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExchange%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-73577%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20while%20configuring%20Hybrid%20%22Powershell%20failed%20to%20invoke%20'Get-HybridMailflowDatacenterIP%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-73577%22%20slang%3D%22en-US%22%3E%3CP%3EI%20laready%20have%20E3%20license%20subscription.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EGot%20to%20know%20from%20Office%20365%20support%20team%20that%20it%20was%20known%20issue%20and%20they%20fixed%20it%20on%20last%20friday.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20for%20your%20response.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-72781%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20while%20configuring%20Hybrid%20%22Powershell%20failed%20to%20invoke%20'Get-HybridMailflowDatacenterIP%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-72781%22%20slang%3D%22en-US%22%3E%3CP%3ELook%20at%20this%3A%20%3CA%20href%3D%22https%3A%2F%2Fsupport.microsoft.com%2Fen-us%2Fhelp%2F3063646%2F-the-term-get-hybridmailflowdatacenterips-is-not-recognized-error-when-you-run-the-hybrid-configuration-wizard%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsupport.microsoft.com%2Fen-us%2Fhelp%2F3063646%2F-the-term-get-hybridmailflowdatacenterips-is-not-recognized-error-when-you-run-the-hybrid-configuration-wizard%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ELooks%20like%20you%20need%20to%20make%20sure%20you%20add%20an%20E3%20license%20to%20your%20admin%20running%20the%20HCW%2C%20in%20order%20for%20the%20configuration%20to%20finalize.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Contributor

Hi,

 

Getting error while running Hybrid setup.

 

HWC0 - Powershell failed to invoke 'Get-HybridMailflowDatacenterIPs': Parameter count mismatch. An unexpected error has occurred and a Watson dump is being generated: Parameter count mismatch.

 

------------

2017.05.22 07:05:49.201 *ERROR* [Client=UX, Functionality=RunWorkflow, Workflow=Hybrid, Task=MailFlow, Phase=CheckPrerequisites, Thread=6] FINISH Time=12.8s Results=FAILED (Prerequisites NOT MET)
2017.05.22 07:05:49.201 *ERROR* [Client=UX, Functionality=RunWorkflow, Workflow=Hybrid, Task=MailFlow, Thread=6] FINISH Time=12.8s Results=FAILED
2017.05.22 07:05:49.216 *ERROR* [Client=UX, Functionality=RunWorkflow, Workflow=Hybrid, Thread=6] FINISH Time=23.8s Results=FAILED
2017.05.22 07:05:49.216 [Client=UX, Provider=OnPremises, Thread=6] Disposing Runspace.
2017.05.22 07:05:49.216 [Client=UX, Provider=Tenant, Thread=6] Disposing Runspace.
2017.05.22 07:05:49.451 *ERROR* [Client=UX, Functionality=RunWorkflow, Thread=6] HCW0000 PowerShell failed to invoke 'Get-HybridMailflowDatacenterIPs': Parameter count mismatch. An unexpected error has occurred and a Watson dump is being generated: Parameter count mismatch.
2017.05.22 07:05:49.466 WARNING [Client=UX, Functionality=RunWorkflow, Thread=6] HCW8055 The Legacy Email Address Policy 'domain' cannot be automatically updated and must be manually upgraded.
2017.05.22 07:05:49.466 WARNING [Client=UX, Functionality=RunWorkflow, Thread=6] HCW8057 Office 365 was unable to communicate with your on-premises Autodiscover endpoint. This is typically due to incorrect DNS or firewall configuration. The Office 365 tenant is currently configured to use the following URL for Autodiscover queries from the Office 365 tenant to the on-premises organization - https://autodiscover.domain.com/autodiscover/autodiscover.svc/WSSecurity.
2017.05.22 07:05:49.544 [Client=UX, Thread=6] UX Time: 5/22/2017 12:04:18 PM +08:00 5/22/2017 3:05:49 PM +08:00 03:01:30.8978209 182

------------------

 

Thanks

2 Replies
Highlighted

Look at this: https://support.microsoft.com/en-us/help/3063646/-the-term-get-hybridmailflowdatacenterips-is-not-re...

 

 

Looks like you need to make sure you add an E3 license to your admin running the HCW, in order for the configuration to finalize.

Highlighted

I laready have E3 license subscription.

 

Got to know from Office 365 support team that it was known issue and they fixed it on last friday.

 

Thanks for your response.