Troubleshooting MSI Uninstall Issues - Intel Pro Network Connections 1713

Published 02-08-2019 12:49 PM 380 Views

First published on MSDN on Jun 07, 2012

I recently upgraded hardware on one of my machines that I use for work. In the process, my network card changed. As part of the system update, I was trying to update the Intel ProSet Network Connection Drivers/Software on my Windows 7 Ultimate 64 bit system. When I tried to uninstall the older version of the Intel Driver Software from the Control Panel, I got the dreaded Error 1713. (See pictures below)



Error 1713. Intel(R) PRO Network Connections cannot install one of it's required products. Contact your technical group.


Doing some internet searching got me to the following Intel support article. After about 25 tries, I concluded that this article wasn’t my solution.


Then I started thinking. When I started the uninstall process, I got a UAC prompt, asking me if I wanted to let C:\Windows\Installer\14805.msi to run. I assumed this was the original MSI package from the installation. Unfortunately, that’s what failed with the 1713 error. I did some more searching about how to remove MSI files via the MSI components built into Windows. I loosely know of MSIEXEC, which is the process that handles all your installs in Windows. A little more searching turned me onto another utility called MSIZAP. This is a tool specifically for removing unwanted MSIs. (Be careful, this tool is a last resort option) It’s part of the Windows SDK, but some internet searches can probably help you find just the tool. (USE AT YOUR OWN RISK)


In order use MSIZAP, you need to pass it a product code, which is a GUID. In order to find this product code, I needed to turn to another tool, also part of the Windows SDK called, MSIINV. This tool spits out all the info you need regarding installed MSIs, including the product code. You’ll need to run this tool from the command prompt, with administrator rights. Just run the exe, but it’s a good idea to output the results to a TXT file. Here’s the syntax to do it.

MSIINV.EXE > outputfilename.txt

After you run MSIINV, open the text file, and search for the package you’re trying to remove. In my case I searched for Intel. I saw this entry.

Intel(R) PRO Network Connections
Product code: {777CA40C-0206-4EF6-A0FC-618BF06BF8D0}
Product state: (5) Installed.
Package code: {F7213E27-AF50-443B-928B-5EB33A12C039}
AssignmentType: 1
Publisher: Intel
Language: 0
Suggested installation location: C:\Program Files\Intel\
Installed from: D:\Drivers\software\Drivers\LAN\APPS\PROSETDX\Vistax64\
Package: PROSETDX.msi
Product Icon: C:\Windows\Installer\{777CA40C-0206-4EF6-A0FC-618BF06BF8D0}\ARPPRODUCTICON.exe
About link:
Help link:
Transforms: C:\Windows\Installer\{777CA40C-0206-4EF6-A0FC-618BF06BF8D0}\1033.mst
Local package: C:\Windows\Installer\14805.msi
Install date: 2007\10\10
Registered to: Ron
Serial Code: none
8 features.
0 features are not used.
0 features are advertised.
0 features are absent.
8 features installed to run local.
0 features installed to run from source.
0 features installed for default.
0 features in some other state.
121 components.
0 qualified.
0 permanent.
0 shared.
0 patch packages.

It matched perfectly with what was in Add/Remove programs, that kept spitting the 1713 error. I also see a product code. I copied the product code for use with MSIZAP. Then I ran MSIZAP. It needs to be run from an command prompt, with administrator priviledges. Here’s what I ran.

MSIZAP.exe T[WA!] {777CA40C-0206-4EF6-A0FC-618BF06BF8D0}

After doing this, I looked back in Add/Remove programs. The entry was no longer there. I kicked off the installer for the latest version of the Intel ProSet Network drives that I pulled from their support site, and it completed. SUCCESS!


I sincerely hope this helps someone who is running into this issue. I know I spent too much time figuring it out.


MSIZAP links

Version history
Last update:
‎Apr 28 2020 12:10 PM
Updated by: