M365 Chat for Teams licence

Copper Contributor

Getting error "you don't have a valid licence, to get access pls check with admin" ??

I'm admin, M365 Business Standard licence assigned

What am I missing?

10 Replies
Have you pursached and assigned copilot license ?
Hi, I have the same problem. We purchased and activated Copilot for M365. The App "Copilot (new)" works in Teams, but not the M365 Chat.
I have the same issue. Already assigned "Microsoft 365 E3" and "Microsoft Copilot for Microsoft 365" license to my account.
Are you using new or old teams ? Have you tried with Teams on the web ?
Pretty sure there is an issue/outage with Microsoft Teams and Copilot licensing since last Friday. I opened a ticket but they are always super slow to acknowledge.

And yes, it does it on the web as well.
We have the same issue in our organization. Please let me know if you come up with a solution.

Seems to have corrected itself this morning? Working for me now. E5 and Copilot for Microsoft 365 License.

@doconnors Same for us. 



I've solved this issue using the app m365 chat and no longer copilot from teams app store. Did you try this?

Also make sure the M365 Chat service is assigned as a license.