M365 Chat can only select from certain files, no searching

Copper Contributor

It appears that when using M365 Chat under Files it shows a list of some recently used files but there is no ability to search or pick a specific file.

 

Is this an issue or a known behavior?

9 Replies
We've seen the same, and it's really annoying. In Powerpoint at least, you can paste a sharepoint URL of a Word document and it'll be able to reference it.

That is what I have found as well. I've also tried pasting the OneDrive link to a file I wanted to summarize only for it to tell me that it either cannot find the file, or it returns information about a completely different file altogether and then asks me if it was the correct file. Very strange behavior.

When I paste the file to a local folder on my PC, it tells me it cannot summarize local files and that they have to be on OneDrive. Clicking the paperclip icon only yields the short list of files as you have seen. Even if I open the file and then go back to teams and refresh the chat, the file doesn't appear there. 

So far, Copilot has been less than helpful in most of the Office-related tasks I've used it for and I am questioning the spend for the Pro license now.

If you type a front slash (/) then start typing the name of the file does it search for the file you want?
Same here. Really frustrating. In Word you can click on the Copilot button and then click Refer to a File and select the file manually.
I am having the same issues
I have about 25TB in my onedrive and it often can’t find the file I need using this technique. I would prefer to navigate to the folder location myself than use the search function
Yeah I find this really frustrating. If you save a new file and want to use that a reference I find it can take up to hr for the index to be able to find it when you start typing the file name. I also find it a paid that that you cant paste a link to OneDrive or SPO to use or have a file browser/picker.
If your are using Copilot chat (M365 Chat) from Microsoft365.com you should have both options to use / or use the paperclip function to reference a file for context.

@mkristjans I have tried both and both give me no files in the file list! How do we get files into the list??