Unable to catalog Windows 10 1809 in WSIM / MDT (added relevant information)

Copper Contributor

WSIM reports an error when I try to build a catalog from Windows 10 Enterprise 1809.


I should have noted here that the version of the ADK I am using is the version mentioned in the error log (10.0.18362.1).


I have tried to get a catalog on three different computers, one running Server 2012 r2, W10 Ent 1803, and W10 Ent 1809 (fresh install).


I downloaded the ISO for 1809 just in case that would make any difference (clutching at straws).



Error log:

14:36 : This application requires version 10.0.18362.1 of the Windows ADK.
Install this version to correct the problem
14:41 :
14:41 : Windows SIM was unable to generate a catalog. For troubleshooting assistance, see the topic: 'Windows System Image Manager Technical Reference' in the Windows ADK User's Guide.
14:41 :
14:41 : System.BadImageFormatException: Could not load file or assembly 'Microsoft.ComponentStudio.ComponentPlatformImplementation, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. An attempt was made to load a program with an incorrect format.
File name: 'Microsoft.ComponentStudio.ComponentPlatformImplementation, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35'

Server stack trace:
at Microsoft.ComponentStudio.ComponentPlatformInterface.Cpi.CreateOfflineImageInstance(OfflineImageInfo imageInfo)
at Microsoft.ComponentStudio.ComponentPlatformInterface.OfflineImageCatalog.Serialize(OfflineImageInfo imageInfo)
at Microsoft.ComponentStudio.ComponentPlatformInterface.OfflineImageInfo.CreateCatalog()
at Microsoft.ComponentStudio.ComponentPlatformInterface.CatalogCreatorImpl.CreateCatalog(OfflineImageInfo offlineImageInfo)
at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs)
at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg)

Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at Microsoft.ComponentStudio.ComponentPlatformInterface.ICatalogCreator.CreateCatalog(OfflineImageInfo offlineImageInfo)
at Microsoft.ComponentStudio.CatalogGenerator.CreateCat(ProgressDialog pd, Object o)

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

2 Replies
best response confirmed by martin-stmtech (Copper Contributor)



I had the exact same error. I uninstalled Windows Assesment and Deployment Kit from the control panel. Then downloaded this version: Windows System Image Manager (10.0.17763.1)



Seems to be working for me now. Hope this will solve your problem!

@MrChoicethank you very much.  It did fix the issue.