SOLVED

Unable to catalog Windows 10 1809 in WSIM / MDT (added relevant information)

%3CLINGO-SUB%20id%3D%22lingo-sub-525581%22%20slang%3D%22en-US%22%3EUnable%20to%20catalog%20Windows%2010%201809%20in%20WSIM%20%2F%20MDT%20(added%20relevant%20information)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-525581%22%20slang%3D%22en-US%22%3E%3CP%3EWSIM%20reports%20an%20error%20when%20I%20try%20to%20build%20a%20catalog%20from%20Windows%2010%20Enterprise%201809.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20should%20have%20noted%20here%20that%20the%20version%20of%20the%20ADK%20I%20am%20using%20is%20the%20version%20mentioned%20in%20the%20error%20log%20(10.0.18362.1).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20tried%20to%20get%20a%20catalog%20on%20three%20different%20computers%2C%20one%20running%20Server%202012%20r2%2C%20W10%20Ent%201803%2C%20and%20W10%20Ent%201809%20(fresh%20install).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20downloaded%20the%20ISO%20for%201809%20just%20in%20case%20that%20would%20make%20any%20difference%20(clutching%20at%20straws).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EError%20log%3A%3C%2FP%3E%3CBLOCKQUOTE%3E%3CP%3E14%3A36%20%3A%20This%20application%20requires%20version%2010.0.18362.1%20of%20the%20Windows%20ADK.%3CBR%20%2F%3EInstall%20this%20version%20to%20correct%20the%20problem%3CBR%20%2F%3E14%3A41%20%3A%3CBR%20%2F%3E14%3A41%20%3A%20Windows%20SIM%20was%20unable%20to%20generate%20a%20catalog.%20For%20troubleshooting%20assistance%2C%20see%20the%20topic%3A%20'Windows%20System%20Image%20Manager%20Technical%20Reference'%20in%20the%20Windows%20ADK%20User's%20Guide.%3CBR%20%2F%3E14%3A41%20%3A%3CBR%20%2F%3E14%3A41%20%3A%20System.BadImageFormatException%3A%20Could%20not%20load%20file%20or%20assembly%20'Microsoft.ComponentStudio.ComponentPlatformImplementation%2C%20Version%3D10.0.0.0%2C%20Culture%3Dneutral%2C%20PublicKeyToken%3D31bf3856ad364e35'%20or%20one%20of%20its%20dependencies.%20An%20attempt%20was%20made%20to%20load%20a%20program%20with%20an%20incorrect%20format.%3CBR%20%2F%3EFile%20name%3A%20'Microsoft.ComponentStudio.ComponentPlatformImplementation%2C%20Version%3D10.0.0.0%2C%20Culture%3Dneutral%2C%20PublicKeyToken%3D31bf3856ad364e35'%3C%2FP%3E%3CP%3EServer%20stack%20trace%3A%3CBR%20%2F%3Eat%20Microsoft.ComponentStudio.ComponentPlatformInterface.Cpi.CreateOfflineImageInstance(OfflineImageInfo%20imageInfo)%3CBR%20%2F%3Eat%20Microsoft.ComponentStudio.ComponentPlatformInterface.OfflineImageCatalog.Serialize(OfflineImageInfo%20imageInfo)%3CBR%20%2F%3Eat%20Microsoft.ComponentStudio.ComponentPlatformInterface.OfflineImageInfo.CreateCatalog()%3CBR%20%2F%3Eat%20Microsoft.ComponentStudio.ComponentPlatformInterface.CatalogCreatorImpl.CreateCatalog(OfflineImageInfo%20offlineImageInfo)%3CBR%20%2F%3Eat%20System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr%20md%2C%20Object%5B%5D%20args%2C%20Object%20server%2C%20Object%5B%5D%26amp%3B%20outArgs)%3CBR%20%2F%3Eat%20System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage%20msg)%3C%2FP%3E%3CP%3EException%20rethrown%20at%20%5B0%5D%3A%3CBR%20%2F%3Eat%20System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage%20reqMsg%2C%20IMessage%20retMsg)%3CBR%20%2F%3Eat%20System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData%26amp%3B%20msgData%2C%20Int32%20type)%3CBR%20%2F%3Eat%20Microsoft.ComponentStudio.ComponentPlatformInterface.ICatalogCreator.CreateCatalog(OfflineImageInfo%20offlineImageInfo)%3CBR%20%2F%3Eat%20Microsoft.ComponentStudio.CatalogGenerator.CreateCat(ProgressDialog%20pd%2C%20Object%20o)%3C%2FP%3E%3CP%3EWRN%3A%20Assembly%20binding%20logging%20is%20turned%20OFF.%3CBR%20%2F%3ETo%20enable%20assembly%20bind%20failure%20logging%2C%20set%20the%20registry%20value%20%5BHKLM%5CSoftware%5CMicrosoft%5CFusion!EnableLog%5D%20(DWORD)%20to%201.%3CBR%20%2F%3ENote%3A%20There%20is%20some%20performance%20penalty%20associated%20with%20assembly%20bind%20failure%20logging.%3CBR%20%2F%3ETo%20turn%20this%20feature%20off%2C%20remove%20the%20registry%20value%20%5BHKLM%5CSoftware%5CMicrosoft%5CFusion!EnableLog%5D.%3C%2FP%3E%3C%2FBLOCKQUOTE%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-525581%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3Emdt%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOperating%20System%20Deployment%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-540223%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20catalog%20Windows%2010%201809%20in%20WSIM%20%2F%20MDT%20(added%20relevant%20information)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-540223%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F332943%22%20target%3D%22_blank%22%3E%40martin-stmtech%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20had%20the%20exact%20same%20error.%20I%20uninstalled%20Windows%20Assesment%20and%20Deployment%20Kit%20from%20the%20control%20panel.%20Then%20downloaded%20this%20version%3A%20Windows%20System%20Image%20Manager%20(10.0.17763.1)%3C%2FP%3E%3CP%3ELink%3A%26nbsp%3B%3CFONT%3E%3CA%20href%3D%22https%3A%2F%2Fgo.microsoft.com%2Ffwlink%2F%3Flinkid%3D2086042%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgo.microsoft.com%2Ffwlink%2F%3Flinkid%3D2086042%3C%2FA%3E%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CFONT%3ESeems%20to%20be%20working%20for%20me%20now.%20Hope%20this%20will%20solve%20your%20problem!%3C%2FFONT%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-541375%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20catalog%20Windows%2010%201809%20in%20WSIM%20%2F%20MDT%20(added%20relevant%20information)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-541375%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F336666%22%20target%3D%22_blank%22%3E%40MrChoice%3C%2FA%3Ethank%20you%20very%20much.%26nbsp%3B%20It%20did%20fix%20the%20issue.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

WSIM reports an error when I try to build a catalog from Windows 10 Enterprise 1809.

 

I should have noted here that the version of the ADK I am using is the version mentioned in the error log (10.0.18362.1).

 

I have tried to get a catalog on three different computers, one running Server 2012 r2, W10 Ent 1803, and W10 Ent 1809 (fresh install).

 

I downloaded the ISO for 1809 just in case that would make any difference (clutching at straws).

 

 

Error log:

14:36 : This application requires version 10.0.18362.1 of the Windows ADK.
Install this version to correct the problem
14:41 :
14:41 : Windows SIM was unable to generate a catalog. For troubleshooting assistance, see the topic: 'Windows System Image Manager Technical Reference' in the Windows ADK User's Guide.
14:41 :
14:41 : System.BadImageFormatException: Could not load file or assembly 'Microsoft.ComponentStudio.ComponentPlatformImplementation, Version=10.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. An attempt was made to load a program with an incorrect format.
File name: 'Microsoft.ComponentStudio.ComponentPlatformImplementation, Version=10.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'

Server stack trace:
at Microsoft.ComponentStudio.ComponentPlatformInterface.Cpi.CreateOfflineImageInstance(OfflineImageInfo imageInfo)
at Microsoft.ComponentStudio.ComponentPlatformInterface.OfflineImageCatalog.Serialize(OfflineImageInfo imageInfo)
at Microsoft.ComponentStudio.ComponentPlatformInterface.OfflineImageInfo.CreateCatalog()
at Microsoft.ComponentStudio.ComponentPlatformInterface.CatalogCreatorImpl.CreateCatalog(OfflineImageInfo offlineImageInfo)
at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs)
at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg)

Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at Microsoft.ComponentStudio.ComponentPlatformInterface.ICatalogCreator.CreateCatalog(OfflineImageInfo offlineImageInfo)
at Microsoft.ComponentStudio.CatalogGenerator.CreateCat(ProgressDialog pd, Object o)

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

2 Replies
Highlighted
Best Response confirmed by martin-stmtech (New Contributor)
Solution

@martin-stmtech 

 

I had the exact same error. I uninstalled Windows Assesment and Deployment Kit from the control panel. Then downloaded this version: Windows System Image Manager (10.0.17763.1)

Link: https://go.microsoft.com/fwlink/?linkid=2086042

 

Seems to be working for me now. Hope this will solve your problem!

Highlighted

@MrChoicethank you very much.  It did fix the issue.