Task sequence software updates hangs downloading

Iron Contributor

Hi all,


SCCM 1810

I'm trying to deploy software updates including third party updates to task sequences, and the computers show downloading x from y and do not continue.

Right now I have a test VM that is stuck like this for more than a day. When I checked  the cache folder it did downloaded the x updates that are displayed on the screen but it doesn't continue.

I searched google and tried several suggestions but no luck.


Any help would be appreciated 

2 Replies

After more digging:


I ran the get-windowsupdatelog command and found exit service code = 0x240001. Googling this I found it means 503 service unavailable.


I have 2000 clients and I ran a long SCCM WSUS maintenance for the database to be healthier. I also have third party updates enabled and I sync HP, Dell and Adobe catalogs. As far as I know my WSUS holds around 15000 updates but my SCCM shows close to 10000 updates.


My Environment has 3 servers: 1 2012 r2 site, system and sql server with 16 GB ram and 4 processors. Also, this is a VM. 1 2012 r2 DMZ server for IBCM including MP, DP and SUP. And 1 2016 remote location server in the same domain with only MP and DP.


I don't have any errors on my servers and everything seems ok. I don't know what to do.

Another update:
Started a task sequence 4 hours ago at the time of writing this post.
When it got to the software updates step the SMSTS.log repeats this line ever minute:
"installswupdate waiting for job status notification".
When looking at the wuahandler log it shows that all updates have installed and on the rebootcoordinator loog it says ccmsetup still running will retry in 1 minute.
I saw forums that said this was a bug in 1806 so maybe this is still a bug in 1810?