Some clients does not display or install required applications

Copper Contributor

Hi,

 

We have a a long time experianced problems related to our clients.

Randomly clients are not displaying or install applications deployed as required and to the device.

 

A lot a troubleshooting as been tried, without any effect.

 

The problem occured about a year ago, maybe around the same time that we decomissioned an addional MP, and only working with the primary site.

 

The problem survived SCCM upgrades along the way, and now we are on latest CB 2207, still experiance the problem.

 

WMI:

On affected computers the WMI object at ROOT\ccm\Policy\Machine\ActualConfig and RequestedConfig:CCM_ApplicationCIAssignment contains the application assignment with UserUIExperiance = True

However the same application in ROOT\ccm\ClientSDK:CCM_Application have the UserUIExperiance = False

 

ActualConfig and RequestedConfig:

instance of CCM_ApplicationCIAssignment
{
AssignedCIs = {"<?xml version='1.0' ?>\n\t\t<CI>\n\t\t\t<ID>ScopeId_09F08FA8-4E6C-4540-9F50-B815031DDA58/RequiredApplication_6ab34f88-381f-4eea-9eee-492648039340/16</ID>\n\t\t\t<ModelName>ScopeId_09F08FA8-4E6C-4540-9F50-B815031DDA58/RequiredApplication_6ab34f88-381f-4eea-9eee-492648039340</ModelName>\n\t\t\t<Version>1.00</Version>\n\t\t\t<CIVersion>16</CIVersion>\n\t\t\t<ApplicabilityCondition>\n\t\t\t\t\n\t\t\t</ApplicabilityCondition>\n\t\t\t<EnforcementEnabled>FALSE</EnforcementEnabled>\n\t\t\t<DisplayName></DisplayName>\n\t\t</CI>"};
AssignmentAction = 0;
AssignmentFlags = "2";
AssignmentID = "{BB71B4F9-7D78-458E-977D-5814D8C7E168}";
AssignmentName = "Cisco AnyConnect Secure Mobility Client - Profile 2021-08-18_Cisco AnyConnect Secure Mobility Client - Profile 2021-08-18_Install";
ConfigurationFlags = "0";
DesiredConfigType = 1;
DisableMomAlerts = FALSE;
DPLocality = 524368;
EnforcementDeadline = "20210918122600.000000+***";
LogComplianceToWinEvent = FALSE;
NonComplianceCriticality = 0;
NotifyUser = FALSE;
OverrideServiceWindows = TRUE;
PersistOnWriteFilterDevices = TRUE;
Priority = 1;
RaiseMomAlertsOnFailure = FALSE;
RebootOutsideOfServiceWindows = FALSE;
Reserved1 = "";
Reserved2 = "";
Reserved3 = "";
SendDetailedNonComplianceStatus = FALSE;
SettingTypes = "";
SoftDeadlineEnabled = FALSE;
StartTime = "20210918122600.000000+***";
StateMessagePriority = 5;
SuppressReboot = 0;
UseGMTTimes = TRUE;
UserUIExperience = TRUE;
UseSiteEvaluation = TRUE;
WoLEnabled = FALSE;
};

 

CCM_Application:

instance of CCM_Application
{
AllowedActions = {};
ApplicabilityState = "Unknown";
Categories = {};
ConfigureState = "NotNeeded";
EnforcePreference = 2;
ErrorCode = 0;
EvaluationState = 0;
FileTypes = "";
FullName = "Cisco AnyConnect Secure Mobility Client - Profile";
Icon = "";
Id = "ScopeId_09F08FA8-4E6C-4540-9F50-B815031DDA58/Application_6ab34f88-381f-4eea-9eee-492648039340";
InformativeUrl = "";
InfoUrlText = "";
InProgressActions = {};
InstallState = "Unknown";
IsMachineTarget = TRUE;
IsPreflightOnly = FALSE;
Name = "Cisco AnyConnect Secure Mobility Client - Profile";
NotifyUser = FALSE;
OverrideServiceWindow = FALSE;
PercentComplete = 0;
PrivacyUri = "";
Publisher = "Cisco";
RebootOutsideServiceWindow = FALSE;
ReleaseDate = "00000000000000.000000+000";
ResolvedState = "Unknown";
Revision = "16";
SoftwareVersion = "2021-09-21";
SupersessionState = "Unknown";
Type = 1;
UserUIExperience = FALSE;
};

 

PolicyAgent.log

Evaluating and applying policy 'CCM_Policy_Policy5.PolicyID="{BB71B4F9-7D78-458E-977D-5814D8C7E168}",PolicyVersion="11.00",PolicySource="SMS:xxx"' to '\\.\ROOT\CCM\Policy\Machine\RequestedConfig' PolicyAgent 12-10-2022 14:53:15 17420 (0x440C)
Applying policy {BB71B4F9-7D78-458E-977D-5814D8C7E168} PolicyAgent 12-10-2022 14:53:15 17420 (0x440C)
Raising event:
instance of CCM_PolicyAgent_PolicyRuleApplied
{
ClientID = "GUID:7734365F-8B4F-4328-B4F6-2AE0EEC3705C";
DateTime = "20221012125315.986000+000";
PolicyID = "{BB71B4F9-7D78-458E-977D-5814D8C7E168}";
PolicyNamespace = "\\\\.\\ROOT\\CCM\\Policy\\Machine\\RequestedConfig";
PolicySource = "SMS:xxx";
PolicyVersion = "11.00";
ProcessID = 17816;
RuleCondition = "";
RuleID = "{Rule_{BB71B4F9-7D78-458E-977D-5814D8C7E168}}";
ThreadID = 17420;
};
PolicyAgent 12-10-2022 14:53:15 17420 (0x440C)
Raising event:
instance of CCM_PolicyAgent_PolicyEvaluationComplete
{
ClientID = "GUID:7734365F-8B4F-4328-B4F6-2AE0EEC3705C";
DateTime = "20221012125315.986000+000";
PolicyNamespace = "\\\\.\\ROOT\\CCM\\Policy\\Machine\\RequestedConfig";
PolicyPath = "CCM_Policy_Policy5.PolicyID=\"{BB71B4F9-7D78-458E-977D-5814D8C7E168}\",PolicyVersion=\"11.00\",PolicySource=\"SMSxxx\"";
ProcessID = 17816;
ThreadID = 17420;
};
PolicyAgent 12-10-2022 14:53:15 17420 (0x440C)

 

PolicyEvaluator.log

Applying policy {BB71B4F9-7D78-458E-977D-5814D8C7E168} PolicyAgent_PolicyEvaluator 12-10-2022 15:20:17 8148 (0x1FD4)

 

- ResetPolicy does not change anything.

- I can find and install the application by triggering it using the CCM_Application Install Method.

- But the visibility is not a garantee

- Reinstall of client does not solve the problem

- The problem is only on random number of computere, with what seems to be random deployments/applications.

- A new Revision of the application seems to solve the problem for the affected computers, but the same appliacation will return to have problems on other computers.

 

Where to start? :(

 

Best Regards

Thomas Nissen

0 Replies