Microsoft Technical Takeoff: Windows and Microsoft Intune
Oct 24 2022 07:00 AM - Oct 27 2022 12:00 PM (PDT)

Application deployed to User Collection not displayed in Software Center

Occasional Contributor

Hi,

I have a problem at a customer where all apps deployed to a user collection are not displayed in software center.

After digging, I have found the following errors in SCClient_<Domain>@user.log

 

The exact translation is ;

GetCategoryValuesAsync: There was no endpoint listening at https://xxx/CMUserService_WindowsAuth/applicationviewservice.asmx that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.. Unable to fetch user categories, no endpoint found. (Microsoft.SoftwareCenter.Client.ViewModels.SoftwareListViewModel+<LoadAppCatalogApplicationsAsync>d__164 at MoveNext)

 

It's followed by the same error message with d__125 as you can see in the screenshots.

This server is a single server hosting MP / DP / SQL etc.. installed by myself (Current Branch 2107).

It's fully https and I never installed and removed Application Catalog role.

In the beginning of this year, app deployment to users was fully functional.

We have Co-Management installed.

 

Can anyone help me please?

Thanks

5 Replies
Hi,
Have you check if application catalogue role wasn't installed from old build ?
If you see this role remove it, when done, change a Software Center setting in client policy and update computer policy
Application Catalog needs to be removed before upgrading to 2107. These features have been deprecated:
https://docs.microsoft.com/en-us/mem/configmgr/apps/plan-design/plan-for-and-configure-application-m...
Hi,
To both of you :
". installed by myself (Current Branch 2107).
It's fully https and I never installed and removed Application Catalog role"
The application catalog was NEVER installed on this MECM server.
I have opened a case with MS. If we find a solution, I'll let you know.
Sorry, I understood your ConfigMgr Server was fine in the beginning of this year, 2107 wasn’t available before August.
2107 is not a base build and required to install 2103 prior to upgrade. I was thinking someone has installed 2103 with the application catalog and you successfully upgraded in 2107 then the problem start
No problem. I have looked everywhere for this message and cannot find anything close to a solution... that's why I opened a case with MS. I'll let you know when this is solved.