After upgrade to Configuration Manager 2211, MicrosoftPolicyPlatformSetup.msi won't install

Brass Contributor

After upgrading to Configuration Manager 2211, manual client installations invoked from <servername>\c$\Microsoft Configuration Manager\Client\CCMSetup.exe fail at the point of installing the Microsoft Policy Platform.


The Application log shows event 11708, "Product: Microsoft Policy Platform -- Installation failed."

CCMSetup.log shows "File C:\WINDOWS\ccmsetup\MicrosoftPolicyPlatformSetup.msi installation failed. Error text: ExitCode: 1603"


I've tried manually installing MicrosoftPolicyPlatformSetup.msi by transferring it to a client PC and double-clicking it.  It shows a GUI during installation, but rolls back the installation and fails with the same error codes.


To work around the issue, I've used a copy of MicrosoftPolicyPlatformSetup.msi from a client installation performed when using Configuration Manager 2207 to install the Microsoft Policy Platform and then run CCMSetup.exe thereafter.


Is there a known issue with the MicrosoftPolicyPlatformSetup.msi that is provided with Configuration Manager 2211?  How can that issue be resolved?  Can I just copy the "good" MicrosoftPolicyPlatformSetup.msi to the x64 subfolder of the C:\Microsoft Configuration Manager\Client folder on the site server?

18 Replies

@SuperMJT I haven’t seen this issue yet. However, you can try capturing the verbose log by using /l*v during manual installation and look for value 3 in the msi log. That should give you the reason for the fatal error code 1603. 

@rahuljindal-MVP Thank you for your response.  I've attached log.txt from a failed install and a screenshot.  Do you have a moment to review them?  Each case in which the Microsoft Policy Platform Installer has failed has been a client PC being upgraded from ConfigMgr 2012 R2.  We're going to try the client install for ConfigMgr 2211 on a new PC soon to see if the same error occurs even if a prior version ConfigMgr client is not present.

best response confirmed by SuperMJT (Brass Contributor)
We did not encounter the issue when installing the ConfigMgr 2211 client on a new PC. So it appears that it's only an issue when upgrading in place from ConfigMgr 2012 R2 to ConfMgr 2211.

@SuperMJT  I am experiencing exactly the same issue, where I am trying to push clients on this ConfigMgr version to a number of computers as a step in migrating them to another site. Exactly the same errors from exactly the same logs, all stemming from the policy platform msi. It seems impossible to do push installations or manual installations of the client if there has ever been a client on the PCs before, even after clearing out certificates, cfg files, registry, WMI namespaces etc. Is there a hotfix or solution to this anywhere in sight? I do not wish to reinstall every computer at this site if I can avoid it in any way. The ConfigMgr version I am trying to upgrade/reinstall from is 1511. If there is a minimum version from which this works, which one would it be?


Kind regards


@rahuljindal-MVP Please see my response below. This is not an isolated incident.
Perhaps you can use your existing environment to push out MicrosoftPolicyPlatformSetup.msi to each PC from the 2207 ISO, then roll out the client upgrade.

@SuperMJT Yes, that seems like a workable path. Is that how you did it or did you simply reinstall the computers?

@SuperMJT - your workaround works! I'm deploying the baseline 2203 platform msi using the old site server and then pushing clients from the new MP. Thank you for your help! Now, Let's hope that A: Someone in the same situation finds this helpful and B: MS will correct the faulty msi in the next CB version. :)
We were performing a number of software updates on all PCs, by accessing each PC directly. It was near the end of this migration that we updated to 2211 and run into the issue, so we just added the manual install of MicrosoftPolicyPlatformSetup.msi at the front of manually upgrading the ECM client.
I'm glad to hear that the workaround is effective. Today, I'm going to try upgrading the ECM client on some PCs that have a slightly older client version and see which ones upgrade successfully. From your experience, it sounds like at least 2203 and 2207 clients can upgrade in place without first manually installing MicrosoftPolicyPlatformSetup.msi.
Yes, it would be interesting to see from which version the problem actually occurs. Granted, 2012 R2 and CB1511 are really old, but I still can't see a logical reason for why such a small msi with no really magical functionality should break like this. Looking forward to your findings. :)
I just encountered exactly this issue i.e. MicrosoftPolicyPlatformSetup.msi fails to install when trying to install a ConfigMgr 2303 client on a Win10 laptop that previously had a ConfigMgr 2012 R2 client on it. I found this thread but time has moved on so the oldest baseline version I can download now is 2303 and thus I can't use the workaround dicussed here because I can't get access to the 2207 ISO.

I have tried everything I can think of to get rid of the 2012 R2 client, delete WMI namespaces, registry info etc. but nothing I have found will allow me to install a supported ConfigMgr client.

I have tried the client with and without the hotfixes for 2303, same fault in each case.

Haven't tried 2309 yet as I think it's still in the "early release" ring.

Does anyone have any thoughts on how to get our many Win10 devices with ConfigMgr 2012 R2 client upgraded with a supported version of the client?

It's starting to look like we have to re-image all the laptops which would be quite disruptive etc.

@matthewj718 I've attached a .zip file containing the older version of the MicrosoftPolicyPlatformSetup.msi that we've installed on client PCs running SCCM 2012 R2, to then allow them to upgrade to newer versions of ECM.  I hope it helps!

@SuperMJT thanks, I really appreciate that. I will give it a try shortly.
Thanks again for your help with the MicrosoftPolicyPlatformSetup.msi. That works fine for me, just as you said above. If I first install it on a Win10 machine with config manager client 2012 R2, using e.g. msiexec /i microsoftpolicyplatformsetup.msi /q I can then do the upgrade to the config manager client 2303 (e.g. I did it via software update) with no problem.
This here saved me big time. I inherited a site that had a failed sccm implementation from 10 years ago. There was no access to the original iso and installers/sccm server. thank you very much

I'm glad to hear that the older .msi file is still helpful!

1 best response

Accepted Solutions
best response confirmed by SuperMJT (Brass Contributor)
We did not encounter the issue when installing the ConfigMgr 2211 client on a new PC. So it appears that it's only an issue when upgrading in place from ConfigMgr 2012 R2 to ConfMgr 2211.

View solution in original post