Problem in the Messages icon badge in The Navigation Bar

%3CLINGO-SUB%20id%3D%22lingo-sub-1430043%22%20slang%3D%22en-US%22%3EProblem%20in%20the%20Messages%20icon%20badge%20in%20The%20Navigation%20Bar%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1430043%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20seeing%20this%20issue%20from%20months.%20The%20number%20of%20unread%20messages%20badge%20on%20the%20messages%20icon%20in%20the%20Navigation%20Bar%20does%20not%20get%20updated%20when%20we%20have%20read%20those%20messages.%20The%20number%20badge%20does%20not%20go%20till%20I%20delete%20those%20messages.%20Please%20fix%20this%20problem%20as%20soon%20as%20possible.%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20image-alt%3D%222020-06-01%20(2).png%22%20style%3D%22width%3A%20345px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F195586i0887F2D95FCEE3E5%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%222020-06-01%20(2).png%22%20alt%3D%22The%20badge%20does%20not%20get%20update%20after%20unread%20messages%20have%20been%20read%20and%20the%20badge%20only%20goes%20after%20those%20messages%20are%20deleted.%22%20%2F%3E%3CSPAN%20class%3D%22lia-inline-image-caption%22%20onclick%3D%22event.preventDefault()%3B%22%3EThe%20badge%20does%20not%20get%20update%20after%20unread%20messages%20have%20been%20read%20and%20the%20badge%20only%20goes%20after%20those%20messages%20are%20deleted.%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1430043%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ECommunity%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1431513%22%20slang%3D%22en-US%22%3ERe%3A%20Problem%20in%20the%20Messages%20icon%20badge%20in%20The%20Navigation%20Bar%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1431513%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F537238%22%20target%3D%22_blank%22%3E%40theshaunsaw%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThanks%20we%20have%20seen%20this%20as%20well%2C%20to%20help%20us%20confirm%20which%20of%20two%20issues%20we%20are%20currently%20tracking%20this%20error%20relates%20to%2C%20could%20you%20confirm%20if%20you%20have%20an%20IPv6%20Connection%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EIf%20you%20are%20not%20sure%20then%20go%20to%20a%20website%20like%26nbsp%3B-ERR%3AREF-NOT-FOUND-test-ipv6.com%26nbsp%3Band%20it%20will%20run%20some%20simple%20connectivity%20tests%20one%20of%20them%20will%20tell%20you%20if%20you%20have%20a%20valid%20IPv6%20Address.%20DO%20NOT%20POST%20IT%20HERE!%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1431901%22%20slang%3D%22en-US%22%3ERe%3A%20Problem%20in%20the%20Messages%20icon%20badge%20in%20The%20Navigation%20Bar%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1431901%22%20slang%3D%22en-US%22%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F10784%22%20target%3D%22_blank%22%3E%40Allen%3C%2FA%3E%3CBR%20%2F%3EI%20checked%20the%20website%20you%20said%20and%20it%20tells%20me%20that%20I%20don't%20have%20an%20IPv6%20connection%20and%20I%20have%20an%20IPv4%20connection%20instead.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1443124%22%20slang%3D%22en-US%22%3ERe%3A%20Problem%20in%20the%20Messages%20icon%20badge%20in%20The%20Navigation%20Bar%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1443124%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F10784%22%20target%3D%22_blank%22%3E%40Allen%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EBy%20the%20way%2C%20how%20it%20shall%20be%3F%3C%2FP%3E%0A%3CP%3EIf%20I%20click%20on%20message%20it%20is%20opened%20and%20keep%20staying%20in%20Unread%26nbsp%3B%20mode.%20And%20in%20general%20I'd%20prefer%20it%20won't%20be%20shifted%20on%20Read%20after%20I%20navigate%20out.%20I%20could%20keep%20it%20for%20later%20answering%20and%20keep%20the%20message%20as%20Unread%20is%20the%20easiest%20way%20for%20such%20notice%20to%20myself.%3C%2FP%3E%0A%3CP%3EI%20make%20shift%20to%20Read%20navigating%20all%20messages%20pane%20or%20with%20Mark%20All%20as%20Read%20-%20at%20least%20for%20me%20it's%20enough.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Super Contributor

I am seeing this issue from months. The number of unread messages badge on the messages icon in the Navigation Bar does not get updated when we have read those messages. The number badge does not go till I delete those messages. Please fix this problem as soon as possible.

The badge does not get update after unread messages have been read and the badge only goes after those messages are deleted.The badge does not get update after unread messages have been read and the badge only goes after those messages are deleted.

 

3 Replies

@TheShaunSaw 

 

Thanks we have seen this as well, to help us confirm which of two issues we are currently tracking this error relates to, could you confirm if you have an IPv6 Connection?

 

If you are not sure then go to a website like test-ipv6.com and it will run some simple connectivity tests one of them will tell you if you have a valid IPv6 Address. DO NOT POST IT HERE!

 

 

@Allen
I checked the website you said and it tells me that I don't have an IPv6 connection and I have an IPv4 connection instead.

@Allen 

By the way, how it shall be?

If I click on message it is opened and keep staying in Unread  mode. And in general I'd prefer it won't be shifted on Read after I navigate out. I could keep it for later answering and keep the message as Unread is the easiest way for such notice to myself.

I make shift to Read navigating all messages pane or with Mark All as Read - at least for me it's enough.