Is it just me or is this AMA forum super slow? Each page load is taking ~15 seconds.

%3CLINGO-SUB%20id%3D%22lingo-sub-917875%22%20slang%3D%22en-US%22%3EIs%20it%20just%20me%20or%20is%20this%20AMA%20forum%20super%20slow%3F%20Each%20page%20load%20is%20taking%20~15%20seconds.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-917875%22%20slang%3D%22en-US%22%3E%3CP%3Eseems%20like%20my%20internet%20connection%20is%20OK...%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F138301i43874BAD42B5DD8C%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_0.png%22%20title%3D%22clipboard_image_0.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

seems like my internet connection is OK...

 

clipboard_image_0.png

32 Replies
Good. It isn't just me. My connection is 50 up/down, but this page is super slow...

@Dan Battagin 

IMHO, Lithium platform, at least in this implementation, is slow in general.

Team,

 

we are seeing a slow down in the service as a result of the spike in views, we will continue to monitor it in realtime and try to keep it as speedy as possible.

Thank you, as always for the feedback.

I am finding it quite buggy and difficult to navigate

I'm starting this thread here because rather than just send the feedback directly to the good folks on the Excel team, I thought it better to include feedback that others may have as well (via replies).

 

I found this AMA to be much less engaging than previous AMAs (on reddit) for several reasons:

  1. The performance of the site is terrible. And it's only getting worse as the AMA goes on. Everyone is seeing it.
  2. The fact that in order to "read more" of a reply I have to navigate to a separate page/URL is ridiculous. There should just be some javascript that shows the rest of the reply. The page navigation is taking 30 seconds per page load. It's unusable. Howie's response is a good example of something I was interested in, but that took me 1 minute to navigate to, and return from:

    clipboard_image_0.png

  3. There is so much whitespace in this forum, that it's impossible to quickly get a read of what's going on. I'm literally scrolling through pages and pages of wasted space just to see what questions were asked. There is no need for a line that identifies the user, then a bunch of whitespace, then a wide spaced block of text, and then more whitespace. A compact view would be much better for this type of real-time interaction (reddit does a good job of this)


    clipboard_image_1.png
Well, even my own post was bitten by the "Read More" which means you have to click through to see the content. And that takes 30+ seconds right now. Sigh.
When you click on "Read more", a new page opens. After returning, the previous page opens again. Who invented this? We had to do it like on Facebook: click on “More” - the page remains in place and only new content is loaded. And yes, my pages are also slowly updating.
Ya, it's pretty slow.

4. Just reloading the main page takes 30 seconds now...and without doing that I can't see any new posts/content.

Yes, I try to remember to press the Ctrl key before clicking More, so the slowness is on anew page

@Dan Battagin , I'd recommend RSS

@Dan Battagin 

I hope Ms will give us a compendium of all queries & their replies.

5. In order to post a question, which only needs a title, you also have to enter a description, or you can't post. This then contributes to the whitespace problem mentioned in #3

Wow, you're right that RSS is way faster and more complete. Still requires a page load to reply, but you're right that reading is much better!