Re-do EDI configuration

%3CLINGO-SUB%20id%3D%22lingo-sub-2562518%22%20slang%3D%22en-US%22%3ERe-do%20EDI%20configuration%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2562518%22%20slang%3D%22en-US%22%3E%3CP%3EFor%20reasons%20I%20won't%20get%20into%2C%20I%20found%20it%20necessary%20to%20use%20the%20configuration%20tool%20to%20unconfigure%20EDI%2FAS2%20in%20BizTalk%202020.%20%22Unconfigure%20features%22%20did%20remove%20the%20checkboxes%20from%20the%20configuration%20tool%2C%20but%20does%20not%20appear%20to%20have%20done%20much%20if%20anything%20to%20the%20BizTalk%20application%20server%20or%20SQL%20database.%20All%20of%20the%20artifacts%20are%20still%20there.%20When%20I%20try%20to%20check%20the%20boxes%20and%20apply%20configuration%20now%2C%20it%20fails%20with%20this%20error%20in%20the%20log%20(which%20is%20not%20super%20helpful)%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%5B2021-07-16%2017%3A42%3A18%3A0541%20Error%20EDIAS2Config%5D%20Failed%20to%20configure%20BizTalk%20EDI%20functionalities.%20(Microsoft.BizTalk.Configuration.EDIAS2.EdiHelper)%3C%2FP%3E%3CP%3EAn%20internal%20failure%20occurred%20for%20unknown%20reasons.%20Error%20Code%3A%20-1061149694%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhat%20is%20my%20best%20option%20at%20this%20point%3F%20This%20is%20a%20new%20development%20environment%2C%20so%20I'm%20not%20concerned%20about%20loosing%20any%20data%2C%20but%20also%20do%20not%20want%20to%20have%20to%20re-do%20the%20entire%20BizTalk%20install%20or%20configuration.%20I%20suspect%20the%20configuration%20tool%20simply%20did%20a%20lousy%20job%20of%20cleaning%20up%20when%20I%20told%20it%20to%20%22unconfigure%22%2C%20which%20is%20preventing%20it%20from%20moving%20forward.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESide%20question%3A%20is%20there%20a%26nbsp%3B%3CSTRONG%3Eright%3C%2FSTRONG%3E%20way%20to%20have%20done%20this%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor

For reasons I won't get into, I found it necessary to use the configuration tool to unconfigure EDI/AS2 in BizTalk 2020. "Unconfigure features" did remove the checkboxes from the configuration tool, but does not appear to have done much if anything to the BizTalk application server or SQL database. All of the artifacts are still there. When I try to check the boxes and apply configuration now, it fails with this error in the log (which is not super helpful):

 

[2021-07-16 17:42:18:0541 Error EDIAS2Config] Failed to configure BizTalk EDI functionalities. (Microsoft.BizTalk.Configuration.EDIAS2.EdiHelper)

An internal failure occurred for unknown reasons. Error Code: -1061149694

 

What is my best option at this point? This is a new development environment, so I'm not concerned about loosing any data, but also do not want to have to re-do the entire BizTalk install or configuration. I suspect the configuration tool simply did a lousy job of cleaning up when I told it to "unconfigure", which is preventing it from moving forward.

 

Side question: is there a right way to have done this?

0 Replies