WVD Gen 1 "couldn't connect because there are currently no available resources"

Copper Contributor

So, we were extremely early adopters of WVD (one of first in world to production). We currently have one with issues, and I had built a backup 15 months ago and parked it (just before COVID freak out). Only ever assigned myself to desktop group. Turned it on because I may need it due to this hanging issue on primary server. 

So for starters, machine apparently was accidentally deleted from domain. I backed doored in with Azure script and was able to rejoin domain. Now all I get is this error from front end (user login). I have double checked and removed and re-added my personal account to Desktop app. I have seen other posts with this, but all were built on newer template (ARM) and don't work for me. 


Additional info:


Error code: 0x3000046
Extended error code: 0x0
Timestamp (UTC): 2021-05-08T16:26:34.622Z
Activity ID: c5b905c3-ce7f-4286-8214-dcb222150000


Any thoughts on this?

4 Replies
Have you tried to reinstall the agent? I’m not sure about WVD Classic, but in the new version of WVD the registration key expires after 90 days. If the session hosts have been powered off for a while, it could be an expired registration key.

@Travis Roberts I appreciate the thought, but I have 3 servers and the other 2 are available in the app and work fine (I did go ahead and unsubscribe and resubscribe because I was hopeful). The documentation is also for the new WVD, as the client version in that article doesn't work for this version and the PowerShell cmdlet mentioned (Export-RdsRegistrationInfo) will not return data for any of my hostpools: "RegistrationInfo does not exist for HostPoolName XXX".


Appreciate the quick response though. Keep 'em coming.



unfortunately we have the same problem. 2 machines of one hostpool were stopped for more then 30 days and now it seems, that they were not registered anymore. we are also early adopters (dec 2019)

and the command (Export-RdsRegistrationInfo) to reregister the host agent is not working too with the same msg: "RegistrationInfo does not exist for HostPoolName XXX".

did you solve your problem?

@Thomas Schwabe 


Yes, I did the following day. Since no one ever replied, I forgot about this whole thread. I ended up spending a lot of time understanding what is never explained, which is how the back end piece actually works. It was never made clear in the ASM version, but is easier to understand in the ARM version, though little has changed. 


While I do not remember the command I ran, I do remember bits and pieces. Coincidentally, last night I removed all users from our ASM model, as I built a new one to migrate to ARM, as it actually works as the original intention, and I am forcing the swap today (and surprisingly already 2 tickets within 45 mins, even though they were told to move over for 2 months).


So it appears, after a certain amount of down time, there is a cert that gets auto updated. You can literally add any server you want to the host pool, just by registering it. So all you need to do is find the correct command (I'll look when I get a chance), unregister the server from the host pool and re-register with the new cert (have to generate a new key).