W10 Azure backup failing on virtual disk service 0x086c6

Brass Contributor

Trying to do a filelevel backup from on-prem W10 build16278.rs3_rel workstation, it is failing on me with the error 'Backup failed because of an unexpected error in the virtual disk service (0x086c86).


- installed the latest MSFT Azure Rec Service agent, v2.0.9085.0

- tried restarting the virtual disk service

- reinstalled Azure backup agent


Already moved from old BackupVault to new Azure Recovery Services in new portal


Only thing is, I'm running W10 with slowring RS3 build that might interfere with the agent ?


Suggestions more than welcome.


BR, Marcel

12 Replies

Now on W10 slowring build 16299.rs3 and still have this problem with latest Azure Recovery Service Agent v9085 ?

Can anyone confirm that this is a problem ? Or am I the only one with this issue ?


BR, Marcel

Im having the same issue with latest Insider Build. Still no fix.

Anyone from the PG reading along here ? Care to share an update ?

Still not working.... :(


Azure backup agent v9085 (latest)

W10 16299.15 (RS3 RTM update)


on-premise W10 backup to Azure broke...


open to suggestions.



I got this error today on a newly installed Windows 10 16299.15 (Fall Creators Update) with Azure backup agent v9085 (still latest). Did you get your to work or at leat an answear from someone?


Best regards


Hi Sten,


Nope, no solution. Haven't heard anything back.


I now have two builds that have this error:

CreatorsUpdate 16299.19

RS4 pre-release 17017.1000




I do have to add, that I created a new W10 VM, fresh install and updated that to 16299.19 (CreatorsUpdate), and Azurebackup runs fine ?????


Cheers, Marcel




Same here. Running on 1709 build 16299.19 and still no luck

Same issue here. Fresh install of Windows and latest agent. Very frustrating.

Anyone got this running already ?


Just upgraded to new RecoveryAgent 2.0.9088.0, still same problem.


Error: The backup could not be completed because of an unexpected error in the Virtual disk service. Restart the Virtual... blablabla.


No errors in the systemlog, the error is referring to. Also looked via VSSAdmin to find roque snapshot, but they don't appear to be there.

Problem on 'normal' desktop PC and on SurfacePro as well.


Time to just abandon Azure Backup and find a supported cloudbackup-solution ?





All I can add is "me too" - Win Pro 1709 Build 16299.19 retail - clean reinstall of the agent 2.0.9088. Error 0x086C6 The backup could not be started because of an unexpected error in the virtual disk service. Seems the disk service starts and runs fine.

Event ID 1001 in application log: 

Fault bucket 128066604633, type 5
Event Name: DPMException
Response: Not available
Cab Id: 0

Problem signature:
P1: CBEngine
P2: 2.0.9088.0
P3: CBPJobFailure
P4: Backup
P5: 34502
P6: -2147024809
P7: -2147024809

I have been working with Azure Developer Support on this and they tell me that it is a known issue and will be resolved in an update for 1709 Build 16299.19


From Azure Support:

Hi Thomas,


I’ve ran a few more tests and was able to reproduce the issue on 3 different computers, without having to do anything additional.


I was also able to have a working backup on a Win10 machine running version 1709, on this particular machine I had the backup already enabled and then upgraded Win10 to 1709. I’m not 100% sure that method will not trigger the issue at all, but worked for me on this test. As you point out below, it is possible to be running that version of Win10 and have it working.


The bug has been confirmed to be an issue with the agent running on Win10 1709 as well as with another version of Windows Server 2016. This is being worked on by the product team at this time.



SE | Azure Backup

It appears that this has been fixed. I have installed and it works for me.


This is from Azure Developer Support:


We just had a new version of the agent released to address this bug, please find it here:




This version was released specifically to address this bug, if you have other machines backing up properly under version 9.0.9085 or 9.0.9088, there is no need to update the agent to this version.


After updating the agent, you may need to run through the “Schedule Backup” wizard on the agent, you do not need to change anything if the schedule is already created as you want it, only go through the wizard hitting next. This in order to have the agent refresh the items to be backed up, if you have the previous failed jobs it may cause the agent to detect non existent paths or files and fail with that error.

Hi Thomas,


Thanks for sharing !

The new version 2.0.9099 did the trick for me. Just updated the backup-client on my W10 17025.rs_prerelease (slow-ring) and now the AzureBackup is running again as supposed to. Will test on WS2016 later and report back.


Cheers, Marcel