Unable to login to azure devops, no notification in Authenticator

Copper Contributor

I'm strugling with Azure Devops since a few days.

The MFA process asks me to approve the notification in Authenticator on my phone, but I never receive it.

Accessing https://account.microsoft.com does trigger the notification in Authenticator.

I've tried the process in multiple browsers and InPrivate windows with no luck.

Please help.

16 Replies
That might be an issue with the authenticator mobile phone due to ISP Network. I also faced this couple of days back then I restarted my phone and then it started coming.

@varunmittal Restarting the phone did not solve the problem.

It sounds like there may be an issue with the Azure DevOps service or your account specifically. A few things you can try include:
Check the Azure DevOps service status page to see if there are any known issues.
Try using a different device or browser to see if that resolves the issue.
Check that you have the latest version of the Authenticator app installed on your phone.
Ensure that your phone's clock is set correctly and that you have a stable internet connection.
Check the Authenticator App to make sure that your account is still linked to the App.
Make sure that the phone number or email associated with your account is up to date.
Try to reset your MFA for Azure DevOps.

It seems that the issue may be related to the Azure DevOps service specifically, since the Authenticator notifications are working correctly for other Microsoft services.
You can try the following steps:

Check your notification settings on the Authenticator app to ensure that notifications are enabled for Azure DevOps.
Check that the Azure DevOps service is linked to the Authenticator app and that the account is set up correctly.
Make sure that you are logged in with the correct Azure DevOps account in your browser.
Try disabling and re-enabling MFA for your Azure DevOps account.
Check your spam/junk folder in your mail in case the notifications are being marked as spam.
If none of these steps resolve the issue, you may want to contact Azure DevOps support for further assistance. They may be able to help you troubleshoot the problem or provide additional guidance.
I've tried all of the above and that did not solve my problem.
One of my new coworker is unable to connect as well.
I understand that MS whish to include this security measure but what can we do when it does not work?
I've tried support by phone and you are told to open a web page. A pity.
I've tried the support page that mislead azure and devops and redirects you to the azure support where only subscription problems could be troubleshooted. Another pity in the way the customers are treated.


How about other options under MFA, test if it works

Other options other MFA are not used by Azure DevOps. I think this is mandatory to use the Authenticator app. Anyway, If I say that I do not have my Authenticator app, I have no other option to use the Authenticator app (again), or to enter a code. This last option is reserved to personal users. I am a professional one.


I thought OTP over SMS, Push Notifications, Yubikey, TOTP, Google Authenticator, etc would be options

@omatrot I have the same issue. Definitely something is borked on the MS side of things, they need to fix this.


If you have a personal account you can put in a OTP code but the code the app generates is 8 digits while you can only put 6 digits into the prompt. So you're locked out of Azure Devops until further notice.

@omatrot Hi. May I know if you have successfully signed in to Azure DevOps now?

I am having the same issue.

No we have open a support ticket with Microsoft as other collaborators are suddenly experiencing the same problem.

@hahoang94 Nope, did not, still locked out.

@molotch I am having the same problem. Maybe it has something to do with AAD. Will talk to my network admin...


Facing same issue, any updates on this.

@MarkusKirschner1970 In my case the problem was in AAD: I already had an 2FA entry for an old iPhone that I no longer use. It had to be removed by the admin, then I could register the new one.

Have you been able to find a solution at the end? I have the same problem now