Unable to delete web app in Azure

%3CLINGO-SUB%20id%3D%22lingo-sub-1566419%22%20slang%3D%22en-US%22%3EUnable%20to%20delete%20web%20app%20in%20Azure%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1566419%22%20slang%3D%22en-US%22%3E%3CP%3EHello.%20I've%20registred%20a%20free%20Azure%20account%20and%20created%20a%20new%20web%20app%20on%20it.%20After%20some%20time%2C%20when%20I%20tried%20to%20open%20it%20on%20Azure%20portal%2C%20it%20has%20given%20me%20a%20404%20error.%20But%20I%20am%20still%20able%20to%20see%20it%20in%20web%20app%20list%20and%20unable%20to%20delete%20application%20plan%2C%20because%20it%20says%2C%20that%20it%20has%201%20application%20in%20it.%20Things%20I%20tried%3A%3C%2FP%3E%3CP%3E1.%20Deleting%20app%20with%20Azure%20portal.%3C%2FP%3E%3CP%3E2.%20Deleting%20app%20with%20Azure%20CLI.%3C%2FP%3E%3CP%3E3.%20Deleting%20application%20plan.%3C%2FP%3E%3CP%3E4.%20Deleting%20resource%20group.%3C%2FP%3E%3CP%3E5.%20Moving%20application%20plan%20to%20another%20group%20and%20deleting%20original%20group.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20was%20able%20to%20delete%20recource%20group%2C%20containing%20web%20app%2C%20and%20it%20seem%20it%20has%20deleted%20correctly%2C%20but%20I%20am%20still%20seeing%20my%20web%20app%20and%20unable%20to%20delete%20application%20plan.%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Hello. I've registred a free Azure account and created a new web app on it. After some time, when I tried to open it on Azure portal, it has given me a 404 error. But I am still able to see it in web app list and unable to delete application plan, because it says, that it has 1 application in it. Things I tried:

1. Deleting app with Azure portal.

2. Deleting app with Azure CLI.

3. Deleting application plan.

4. Deleting resource group.

5. Moving application plan to another group and deleting original group.

 

I was able to delete recource group, containing web app, and it seem it has deleted correctly, but I am still seeing my web app and unable to delete application plan.

5 Replies

Hi @MiroslavBogatyrev,

 

How long ago you deleted the Resources?

Maybe it, like some things, takes some time until it is shown correctly in the Azure Portal. Had the same Problem several times in the past. Maybe wait some more time and if the Problem still exists, open a Support Ticket with the Azure Support.

 

Kind Regards, Peter

Hi,@Peter_Beckendorf . Thank you for answering.

 

I've deleted this app in Monday and it's still shows as running in web app list.

Hi @MiroslavBogatyrev,

 

That is realy long, is there any return code when trying to delete it with the CLI?

 

Kind Regards, Peter

No, there CLI writes nothing, when I try to delete web app. But when I try to delete the application plan, then I receive conflict error.

Thank you for answering.

@MiroslavBogatyrev 

 

So you tried this command in CLI and no Output was given back?

 

az webapp delete --name "MyWebapp" --resource-group "MyResourceGroup"

 

There should be at least some response in case of a failure.

When deleting the App Plan befor deleting the Web App, sure, there will be a error.

 

What comes back when you do this:

 

az webapp list --subscription "subscriptionID/name"