Unable to delete network resources in resource group

Copper Contributor

For a lab I deployed Data Factory with networking resources (private endpoint, vnet, etc).

After my tests I wanted to delete the resource group. Most resources got deleted, but it fails to delete the Data Factory and its private endpoints and network interfaces.


I get a simple "Internal server error" message without much meaning.


I have tried using, but that did not help.


My payment plan does not allow MS support ticket. How can I get the resource group deleted?



3 Replies
Strange can you try to delete the nested resources first : Private endpoints , Network Interfaces ?
The issue has been there for more than a year. I just haven't figured out how to fix it, or whom to contact.

I have tried everything that I can think of. I have also tried to delete the nested resources first in all kinds of combinations.
I think the first full delete of all resources in the resource group caused catch 22, where it can't delete the resource because it expects something to exist that actually did get deleted.
best response confirmed by ahvallentin (Copper Contributor)

@ahvallentin - There are news - Microsoft have added tech support to the visual studio subscriptions, so I have now raised an MS support ticket and expect that they can help me to delete the resources in the backend.