The Captcha keep failing when create a Microsoft Entra ID tenant in pay as you go

Copper Contributor

I have Azure "Pay as you go" Subscription. I am trying to create another Azure AD tenant (now called Microsoft Entra ID tenant), but the captcha keep failing times after times after times.

I tried many browsers, and in Incognito modes, on different times, with no success.

I found the following answer, but it says that on Free trial you cannot create a second tenant, but I am on Pay as you go and not free trial.

P.S: I am able to create B2C tenants, but not the B2B or the Entra.


I already have two Entra tenants, the default one with my subscription and one I was added to because I contributed in Microsoft Community which has no access at all on Azure.

4 Replies



What kind of account are you using to create your tenant?

As I said, I am on "Pay as you go" Subscription. and I have on my default tenant one user which is my only login user, and it is assigned "Global Administrator" role.

Were you ablet to find a solution? The same thing is happening to me. Before I was trying to create a new Entra ID tenant and the captcha was always failing, so I decided to remove all but the default and create a new one and now the option is disabled. I also have a "Pay as you go" subscription.

Still not able to make it work. And no one answer my question either here or on stackoverlow