Self-service group membership




In Azure Active Directory -> Groups -> General I enabled the self-service group membership. The first option to enable it is easy, the second is a bit confuse if it should be set as Yes or No and I found both information in different sources. I tried both.



Security Groups self-service is enabled:



I created two new users to test the self-service feature. I tried to access the self-service portal ( using one of the accounts. The myApps appear to work fine, but when I change to group management, I get an error message. The following one:




It appears there is something missing, but I don't know what is missing. Any help will be very welcome.

Kind Regards,


2 Replies
Hello, do you have a solution to this question in the meantime? Best regards, F.

@Frank007 ,




Unfortunatelly this was a long time ago. I solved the problem, but I don't remember exactly how.

I can say I used the two links below. Besides that, there is an additional trick: You can only manage the groups owned by yourself. If the groups were created by other user, you can't manage them.

Users can request to join a group and the group owner can approve or reject the request.

The links:

 Self-Service Group Management  


Access Panel for Self-Service Group Management