Secure Score Restricted

Copper Contributor

I am using the Azure portal Microsoft Defender for Cloud.  When I click on secure score only one of my subscriptions is showing a score.  My other subscription says restricted and doesn't show a score.  It was showing a score last week so not sure what happened.  Does anyone have any ideas?


Thank you.

13 Replies

I'm also seeing this issue as of today.  Maybe Microsoft has changed something on the backend?

@devan101010interesting.  I have a support request in to Microsoft.  I am waiting for a reply.  I will post here when I get a reply.  Thanks for replying.

We are having the same issue.  Following this thread.@HmeltonAppDev 

I am also having the same problem. I was able to see my Secure Score yesterday and then today is in a restricted status. Microsoft must have changed something - sounds like they removed permissions somehow for us to view the Secure Score.
Same is happening with us. This just recently changed. I was able to view everything this morning.

I was able to see all my subscriptions this morning, then this afternoon only half, and by the end of the day all subs are showing restricted. I checked RBAC and nothing has changed. It may be something with the back end API.

Yep I can’t see any of our subscriptions now. Still no response from Microsoft tech support.
I just checked, and I see about 20% of my subs. 80% are still showing restricted. I'm hoping by morning everything will be back to normal.
I can now see the secure score for all of my subscriptions.

@lmpalermo  I can see all of my secure scores now too.  Never did get a reply from MIcrosoft support.

I can now see my Secure Scores too. I am sure they fixed it. It appears we had lost permissions to view this. I am pretty certain they rolled back whatever change they had made. It would be good if they can at least respond or shed light on what caused this.
I don't think it was a permission issue. My permission is set a the tenant level, not at the subscription level. Maybe it was just a glitch in the Matrix :)
Yes you are right on that one, it was not a permissions issue. It seems the Secure Score is now called 'Secure posture'' Looks like they were updating and rebranding it i assume :)