Moving a Subscription to another Tenant fails

%3CLINGO-SUB%20id%3D%22lingo-sub-1673302%22%20slang%3D%22en-US%22%3EMoving%20a%20Subscription%20to%20another%20Tenant%20fails%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1673302%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20are%20looking%20to%20move%20an%20EA%20Subscription%20to%20a%20different%20Tenant%20under%20the%20same%20billing%20account.%20We%20have%20followed%20the%20Microsoft%20documentation%20and%20given%20a%20user%20account%20the%20relevant%20access%20in%20both%20Tenants.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20we%20click%20on%20Change%20Directory%20within%20the%20Subscription%2C%20we%20can%20see%20the%20destination%20Tenant%20and%20select%20it%2C%20but%20when%20we%20click%20change%2C%20we%20get%20the%20following%20error%20%3CSTRONG%3E%22%26nbsp%3B%3CSPAN%3ECannot%20change%20directory.%26nbsp%3B%3C%2FSPAN%3EFailed%20to%20change%20subscription%20directory.%20Please%20try%20again%20later.%22%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENo%20idea%20what%20is%20causing%20the%20above%20issue%2C%20the%20account%20that%20is%20being%20used%20has%20all%20the%20relevant%20permissions%20e.g.%20Owner%2C%20Global%20Admin.%3C%2FP%3E%3CP%3E%3CBR%20%2F%3EAny%20help%20or%20pointers%20would%20be%20great%2C%20thanks.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1673302%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAzure%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EAzure%20Resource%20Management%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Highlighted
Visitor

Hi,

 

We are looking to move an EA Subscription to a different Tenant under the same billing account. We have followed the Microsoft documentation and given a user account the relevant access in both Tenants.

 

When we click on Change Directory within the Subscription, we can see the destination Tenant and select it, but when we click change, we get the following error Cannot change directory. Failed to change subscription directory. Please try again later."

 

No idea what is causing the above issue, the account that is being used has all the relevant permissions e.g. Owner, Global Admin.


Any help or pointers would be great, thanks.

1 Reply
Highlighted

@chriskowalski 

I had some issue with CSP type of subscriptions because they don't provide the same set of services. On the other hand, most of the tasks related to migration are not that simple and cannot be accomplished thought the portal UI. You may need to work closely with MS Support as there are many things that can be done on the backend only (especially what concerns directory change).