Logic App - HTTP Calls with PATCH ( HTTP method ) is not going through WITHOUT a Request Body

Copper Contributor

Hi All,

I am trying to make a HTTP call using HTTP METHOD -PATCH to an external system via Logic App. The API doesn't have a request body and it has path parameters and headers in place. While invoking the external system via HTTP connector in the logic App, encountered the following error- "415-Unsupported media type - Check the content type of your request."

But the same request works in Postman (No Request Body) and I was able to receive the response from the external system.

 

Tried a work around of passing an Empty Json Object as part of the request Body in the logic App. Now the API call goes through but it ended up with unsuccessful response as the request body is not expected in the target system.

 

Looks like it is a constraint in the Logic App, that the PATCH mode always looks for a request Body.

Kindly let us know if we do have any solution for this scenario.

2 Replies

Hi @Induja_Muthusamy,

Did you try adding: "Content-Type": "application/json" as a header to the empty request body?

(Shown in the attached image)

Hi @tzahiariel,
Yes ,tried that. With content-type header and with empty JSON object ,the request reached the target system but received a error response from the target system as the request body is not expected in the target system.
Is there any solution to get through the API call without passing the Request Body in PATCH mode ?