Invalid login credentials

Copper Contributor

Azure Host server setup and ready for use 

Microsoft remote desktop get to final screen of negotiating credentials 

and Invalid login credentials please re-enter username and password is the message I keep getting 

14 Replies

To clarify.

  • you have a Windows based VM in Azure
  • When you try to RDP to the VM, you are told the password is incorrect.

you have an option via the portal to reset the password, this requires the VM agent to be installed.


Kent Gaardmand:

I tried that also several times before posting and it did not work.

I hope below give you the clarity you where looking for so that you can help further if you can.


My specs are:

Mac Book Pro with Apple OS

(MRD) Microsoft Remote Desktop App from App Store

Azure VDI Cloud for Desktop Virtualization 

*Those specs should work seamlessly like they advertised:

I am unaware of a product called Azure VDI Cloud for Desktop Virtualization.

The link you provided just refers to running a VDI infrastrcture on 2016 servers.


How did you deploy the VDI infrastrcture? right now im guessing its just IaaS machines.

There is a deployment package defined in the market place that uses ARM templates to help you deploy the infrastructure. this link would describe that process


the market place would have asked you the following:

  • Administrator user name and password. This is a new user that will manage the deployment.
  • DNS name and AD domain name. These are NEW resources that are created. Make sure the names are meaningful.
  • VM size. You get to choose the size of VMs to use for the RDSH endpoints. You can also manually change the sizes after the initial deployment to help you optimize the VMs for your workloads and for cost.

But this would not intergrate with you current directory, also as an administrator you may need to connect using /console



if i misunderstood, perhaps you could provide screen shot of the deployed resources in azure ?

It will take me like 5 hours to confirm if your last reply worked for me or not.

But in effort to help you help me better here is the screen shot you requested plus more.


Thanks this confirms that you are indeed running an IaaS infrastructure.

The pictures you sent me is of a Single VM in azure. try mstsc.exe /console, connect to the ip of the VM and use the username and password you specified during the installation process 

I believe this is the orgin of my problem.

During the installation process I was unable to get the serve to accept my password I choose.

My Apple OS suggested one for me and I accepted it without recording and the server accepted it also.

Later I earned more understanding of what was needed to create a password that I would remember.

Since losing orginal password, resetting password does not fix my login issue.

My next course of action that I am going to try is to delete my Laas infastructure and build a new one using the understanding that I have earned recentlt and this link you sent me





Ok, remeber that the deployment you are using gives you a local login.

But the machine is also a domain controller, so you have to specificy a domain user for login or try:



Thanks for all your help I was able to log in.

Anytime, did you access the current installation or did you start over ?

I did the installation over and got in without an issue.


I had this issue the second time I tried to access my (shut down and restarted) VM - but it was because I was using an RDP file from before and I hadn't realised that the DNS gets reallocated (of course it does!). Solution was to set up a 'DNS name label' and you then endup with e.g. which auto routes each time.