GitHub App authentication for Azure Pipelines causes webhooks to dissapear

Copper Contributor



we are using GitHub as the code repository service together with Azure DevOps Pipelines for CI/CD.


  • All the pipelines need to have their triggers authenticated to GitHub in order for the pipelines to trigger
  • Authentication works either with personal OAuth Service Connections or via the Azure Pipelines App for GitHub
  • The recommended way is using the Pipelines App

The problem: when I authenticate the pipeline trigger via the GitHub Azure Pipelines App, the webhooks from the repository which the pipeline is pointing to dissapear and the automatic triggering stops working!


To make the issue even more ridiculous - we have 5 pipelines but only with 4 of them this happens! One is working completely fine with with the recommended GitHub App authentication.


What I tried:

  1. Recreating service connections in Azure DevOps
  2. Reinstalling the Azure Pipelines GitHub App
  3. Recreating the pipelines

Nothing worked, I am forced to use OAuth which is always throwing a warning to switch to app authentication because it's better performing and more reliable. 



Quite ridiculous to recommend a certain way of doing things, then making it work less reliable than the not-recommended way. 


Anyone has any ideas? Thanks in advance.

0 Replies