Cannot Join Windows 10 PCs to Azure AD

Copper Contributor



Until yesterday, I have been joining Windows 10 PCs to our Azure AD without any problems.  Now when I go to Settings >Accounts >  Access work or School > Connect > Join this device to Azure Active Directory I get prompted to enter the Work or School account, but when I enter the account and click next, nothing happens.  I don't get prompted for a password, nothing shows up in the event logs, and the device does not join the Azure AD.


I have reviewed our Azure Device Settings, and users may join to Azure AD, users may register their device with Azure AD, multi-factor authentication is not required, and the maximum number of devices per user is at the default of 20.  The devices are being registered by the account that the end user uses, so we have not surpassed the maximum number of registered devices per user.


I have tried this on Windows 10 1703 and previous versions.  Any help would be much appreciated.




8 Replies

Hi Tod,


Quick question, Did you check in AAD relevant user device setting to see it shows there ?

I did.  The relevant user shows 'no device found."  I have tried using several different user accounts, including mine.  I have not previously had any trouble joining devices.

Few steps to troubleshoot 


1. Remove any existing accounts in work school ?

2. Restart the PC

3. Try to add it again 


Follow this link for step by step  guide

Thanks.  These are clean Windows 10 installations, and one is a brand new PC we are trying to join during the OOBE startup.  they have never been joined to Azure AD, and never had a Work/school account added.



I have done testing with my lab as you mentioned I setup my win 10 VM using O365 user when fresh installation and it shows in the AAD.


Which windows 10 are you using (1703) ?win10-4.PNG

Yes, the first PC is Windows 10 1703.  It is important to note, that when I follow the instructions at, I never get prompted for the password as shown in step 6.

I used the Windows 10 1703 for test and It works without any trouble. 

@Tod Ashby  Hi!

I just had the same issue. In my case it was just my dumb mistake, that i was logged in with a user without local admin rights. Then the "Join Azure AD" option is not presented.