Can't connect Cloud Shell to my storage account

New Contributor



I opened a new Azure Cloud Shell tab in Windows Terminal and got this:


You have not set up your cloud shell account yet. Please go to to set it up.


Fine, so I headed there and filled in the necessary details:



When I hit Attach storage, I get this error message:


The user setting is invalid and has been removed. 
Error: resource is not found:
'/subscriptions/<GUID to my subscription>/resourcegroups/<Not the name of my resource group>/providers/Microsoft.Storage/storageAccounts/<a storage account I have deleted>'


I have tried:


* Adding a new file share to my storage account and entered that into the wizard

* Deleted my storage account and let the Cloud Shell wizard create the storage account

* Tried different browsers in case there was some kind of cache issue


It doesn't make sense to me that it points to a resource group with the wrong name. I gave it the right one


Any help is appreciated :) Thanks!


3 Replies
best response confirmed by azureuser255 (New Contributor)
Have you tried creating a storage account and file share manually, then select those, and seeing if that works?

@gilblumbergI hadn't tried creating both the storage account and the file share manually.. I did so and now it works. Thanks for taking the time to answer!

Brilliant, glad I could help!