Azure - Workday SSO Logout

%3CLINGO-SUB%20id%3D%22lingo-sub-134460%22%20slang%3D%22en-US%22%3EAzure%20-%20Workday%20SSO%20Logout%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-134460%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20All%2C%3CBR%20%2F%3E%3CBR%20%2F%3EWe%20have%20the%20Azure%20-%20Workday%20SSO%20configured%20and%20it%20is%20working%20fine%2C%20but%20I%20cannot%20logout%20from%20workday.%20As%20per%20the%20config%20doc%2C%20the%20logout%20URL%20must%20be%20%22%3CA%20href%3D%22https%3A%2F%2Flogin.microsoftonline.com%2Fcommon%2Fwsfederation%3Fwa%3Dwsignout1.0%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Flogin.microsoftonline.com%2Fcommon%2Fwsfederation%3Fwa%3Dwsignout1.0%3C%2FA%3E%22.%20This%20was%20configured%20in%20Workday.%20So%20when%20I%20want%20to%20logout%2C%20it%20is%20failing%20(I%20do%20see%20this%20URL%20in%20browser)%20with%20the%20error%3CBR%20%2F%3E%3CBR%20%2F%3E%3CBR%20%2F%3ESign%20In%3CBR%20%2F%3ESorry%2C%20but%20we%E2%80%99re%20having%20trouble%20signing%20you%20in.%3CBR%20%2F%3E%3CBR%20%2F%3EWe%20received%20a%20bad%20request.%3CBR%20%2F%3E%3CBR%20%2F%3EAdditional%20technical%20information%3A%3CBR%20%2F%3ECorrelation%20ID%3A%20xxxxx-xxxxx-xxx-xxx-xxxxxx%3CBR%20%2F%3ETimestamp%3A%3CBR%20%2F%3EAADSTS20012%3A%20An%20error%20occurred%20when%20we%20tried%20to%20process%20a%20WS-Federation%20message.%20The%20message%20was%20invalid.%3CBR%20%2F%3E%3CBR%20%2F%3EAny%20thoughts%20on%20this%20error%3F%20Where%20can%20I%20check%20the%20logs%20(I%20did%20check%20the%20troubleshooting%20and%20audit%20log%20sections)%3F%20Thanks.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-134460%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAzure%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
New Contributor

Hi All,

We have the Azure - Workday SSO configured and it is working fine, but I cannot logout from workday. As per the config doc, the logout URL must be "https://login.microsoftonline.com/common/wsfederation?wa=wsignout1.0". This was configured in Workday. So when I want to logout, it is failing (I do see this URL in browser) with the error


Sign In
Sorry, but we’re having trouble signing you in.

We received a bad request.

Additional technical information:
Correlation ID: xxxxx-xxxxx-xxx-xxx-xxxxxx
Timestamp:
AADSTS20012: An error occurred when we tried to process a WS-Federation message. The message was invalid.

Any thoughts on this error? Where can I check the logs (I did check the troubleshooting and audit log sections)? Thanks.

0 Replies