Azure Web App Bot Connection Issues

%3CLINGO-SUB%20id%3D%22lingo-sub-660863%22%20slang%3D%22en-US%22%3EAzure%20Web%20App%20Bot%20Connection%20Issues%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-660863%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20are%20exploring%20azure%20bot%20services%3B%20we%20have%20created%20a%20web%20app%20bot%20service%20on%20Azure%20and%20is%20using%20channel%20redirection%20to%20connect%20to%20the%20actual%20bot%20hosted%20on%20an%20AWS%20Instance.%3C%2FP%3E%3CP%3EFor%20the%20messaging%20endpoint%20we%20have%20given%20the%20URL%20of%20the%20bot%20on%20AWS%3B%20however%20this%20is%20not%20working%20as%20expected.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIt%20gives%20below%20error%3A-%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-left%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F116728i58928D7AFFD33CEB%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22chatbot-azure.png%22%20title%3D%22chatbot-azure.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CDIV%20class%3D%22dialog-mask%22%3E%3CDIV%20class%3D%22dialog%20channellog-dialog%22%3E%3CDIV%20class%3D%22channellog-panel%22%3E%3CTABLE%3E%3CTBODY%3E%3CTR%3E%3CTD%3EThere%20was%20an%20error%20sending%20this%20message%20to%20your%20bot%3A%20HTTP%20status%20code%20GatewayTimeout%3C%2FTD%3E%3C%2FTR%3E%3C%2FTBODY%3E%3C%2FTABLE%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20advise%20on%20getting%20this%20sorted%20would%20be%20much%20appreciated.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-660863%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EApp%20Services%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EAzure%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EBot%20Services%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ENetworking%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EWeb%20App%20Bot%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Occasional Contributor

We are exploring azure bot services; we have created a web app bot service on Azure and is using channel redirection to connect to the actual bot hosted on an AWS Instance.

For the messaging endpoint we have given the URL of the bot on AWS; however this is not working as expected.

 

It gives below error:-

 

 

chatbot-azure.png

There was an error sending this message to your bot: HTTP status code GatewayTimeout

 

Any advise on getting this sorted would be much appreciated.

 

 

0 Replies