Azure Update management - error HRESULT: 0x80072F8F

Copper Contributor

Azure Update management not working


Azure Windows based VM

Forced Tunnelling

Onpremise Firewall supports only IP Addresses

Update management error:


Exception from HRESULT: 0x80072F8F


System.Runtime.InteropServices.COMException (0x80072F8F): Exception from HRESULT: 0x80072F8F at Microsoft.EnterpriseManagement.Mom.Modules.ChangeTracking.WUA.IUpdateSearcher2.EndSearch(ISearchJob searchJob) at Microsoft.EnterpriseManagement.Advisor.PatchManagement.WindowsUpdateHelper.GetUpdateSnapshot(TimeSpan timeout, Boolean onlineSearch, DateTime lastTimeUpdateApplied, IAutomaticUpdates2 automaticUpdates, UpdateModuleState state)


Due to Forced Tunnelling the traffic has to go to the onpremise FW.

Unfortunately the onpremise FW allows only IP Addresses and as per the following article:

It suggest to allow port 443 for url:

Azure Public




* & *

Though, no IP address that I can NSlookup for *”

Therefore, trying the alternate approach:


  1. Tried enabling service Tags via Azure Firewall, but as the traffic still goes to Onpremise FW we either need the IP Address for the URL to be allowed

  2. Else, use User Defined Route (UDR) to direct the Traffic for Service TAGS: “Azure Monitor” & “GuestAndHybridManagement“ via UDR and allowed the same using CLI, still no good.

Checking for suggestions.

Thanks in advance to reading through.

0 Replies