Azure backup- Deployment to resource group 'ResourceGroupName' failed.

%3CLINGO-SUB%20id%3D%22lingo-sub-314313%22%20slang%3D%22en-US%22%3EAzure%20backup-%20Deployment%20to%20resource%20group%20'ResourceGroupName'%20failed.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-314313%22%20slang%3D%22en-US%22%3E%3CP%3EI%20can't%20enable%20Azure%20backup%20on%20some%20my%20VMs%20in%20Azure.%20I%20have%20already%20virtual%20machines%20migrated%20from%20classic%20to%20ARM%2C%20but%20disks%20for%20a%20few%20one%20are%20still%20stored%20in%20Classic%20storage.%20If%20I%20try%20to%20enable%20backup%20I%20receive%20error%20%22Deployment%20to%20resource%20group%20'ResourceGroupName'%20failed.%22%20%22Write%20ProtectedItems%20Failed%22%20I%20also%20can't%20migrate%20this%20disk%20to%20ARM%20using%20standard%20migration%20procedure.%20On%20new%20machines%20or%20corrected%20migrated%20I%20can%20enable%20Azure%20backup%20without%20any%20problems.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-314313%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAzure%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EAzure%20Backup%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-315101%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20backup-%20Deployment%20to%20resource%20group%20'ResourceGroupName'%20failed.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-315101%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%3EI%20know-%20storage%20migration%20is%20a%20solution%20%3A)%3C%2Fimg%3E%20but%20I%20get%20some%20errors%20during%20migration%20process.%20I%20migrated%20all%20environment%20and%20commit%20this%20process%20but%20one%20classic%20storage%20account%20finish%20with%20errors.%20OK%2C%20I%20was%20hoping%20that%20there%20is%20some%20tricky%20operation.%20I%20will%20retry%20next%20days.%20Thanks%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-314320%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20backup-%20Deployment%20to%20resource%20group%20'ResourceGroupName'%20failed.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-314320%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%20class%3D%22UserName%20lia-user-name%20lia-user-rank-Occasional-Visitor%20lia-component-message-view-widget-author-username%22%3E%3CSPAN%20class%3D%22%22%3EHi%26nbsp%3B%3CSTRONG%3Erszitoptipl%2C%3C%2FSTRONG%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22UserName%20lia-user-name%20lia-user-rank-Occasional-Visitor%20lia-component-message-view-widget-author-username%22%3E%3CSPAN%20class%3D%22%22%3E%3CSTRONG%3E%26nbsp%3B%20you%20can%20see%20the%20migration%20resource%20from%20Azure%20classic%20into%20Azure%20ARM%20Deployment%20here.%3C%2FSTRONG%3E%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22UserName%20lia-user-name%20lia-user-rank-Occasional-Visitor%20lia-component-message-view-widget-author-username%22%3E%3CSPAN%20class%3D%22%22%3E%3CSTRONG%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-machines%2Fwindows%2Fmigration-classic-resource-manager-overview%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Fvirtual-machines%2Fwindows%2Fmigration-classic-resource-manager-overview%3C%2FA%3E%20%3C%2FSTRONG%3E%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

I can't enable Azure backup on some my VMs in Azure. I have already virtual machines migrated from classic to ARM, but disks for a few one are still stored in Classic storage. If I try to enable backup I receive error "Deployment to resource group 'ResourceGroupName' failed." "Write ProtectedItems Failed" I also can't migrate this disk to ARM using standard migration procedure. On new machines or corrected migrated I can enable Azure backup without any problems.

2 Replies

Hi rszitoptipl, 

  you can see the migration resource from Azure classic into Azure ARM Deployment here.

 

https://docs.microsoft.com/en-us/azure/virtual-machines/windows/migration-classic-resource-manager-o...

 

I know- storage migration is a solution :) but I get some errors during migration process. I migrated all environment and commit this process but one classic storage account finish with errors. OK, I was hoping that there is some tricky operation. I will retry next days. Thanks