WVD - Unable to access after restore

Copper Contributor

Hi All,


I was testing out Windows Virtual Desktop when I tried to restore a single Windows 10 Multi session host using Azure Backup. The restore operation completed successfully and I can see that the VM is back online. However whenever I try to connect with the Remote Desktop app on my endpoint I get an error message stating internal error with no further information.


I connected to our domain controller which is on the same subnet and attempted to connect from there but I also received the following error message...


The remote computer that you are trying to connect to requires Network Level Authentication (NLA), but your Windows domain controller cannot be contacted to perform NLA.


Connectivity does appear to be working as I was prompted for credentials when connecting from the Domain Controller.


I have tried to run DisableNLA from the Azure portal however this seems to fail as I never get any output. I have also attempted to restore a different image but the result was the same.


Would really appreciate some assistance with this! Thanks.

2 Replies

@blcyb : I realize the response is a bit delayed, but were you successfully able to restore? Or was it still stuck in a broken state?

@blcyb Hi,

The particular error that is being displayed indicates that the restored VM has lost trust with the Domain controller. 

If you are able to connect to the directly from RDP/Bastion (not through WVD) you can (re)domain join the vm and that should fix it.

If you are NOT able to connect to the VM try running the DSC to do domain join. Last time that is what I used to fix the error you are getting.


FYI - this is not specific to WVD.