WVD Remote Desktop Client doesn't show provisioned tenant and hostpool

Copper Contributor

WVD Remote Desktop Client fails to show the created tenant and hostpool. But the HP shows available in powershell.

SessionHostName    : fshp-0.azureproduction.onmicrosoft.com
TenantName         : fstenant
TenantGroupName    : Default Tenant Group
HostPoolName       : fshostpool
AllowNewSession    : True
Sessions           : 0
LastHeartBeat      : 3/27/2020 2:25:51 AM
AgentVersion       : 1.0.1288.2700
AssignedUser       :
OsVersion          : 10.0.18363
SxSStackVersion    : rdp-sxs191213001
Status             : Available
UpdateState        : Succeeded
LastUpdateTime     : 3/27/2020 2:26:19 AM
UpdateErrorMessage :


Tried creating multiple tenants and hostpools. HP Deployments was successful but fails to show up in the client.

It looks like your system administrator hasn’t set up any resources for user@domain.com yet. Please choose a different account or try again. If you believe you have received this message in error, please contact your system administrator.


1 Reply

Issue Solved:

I didn't give default desktop users while creating the host pool. Added a user using the command Add-RdsAppGroupUser and it came up. Sorry for the trouble.