WVD - [Newtonsoft.Json.Linq.JToken]' for the template parameter 'newOrExistingVnet' at line '152'

Copper Contributor

Hi there,


I'm new to Azure, and trying to wrap my head around WVD. My main goal is to evaluation my companies software running in the WVD environment. I managed to register our O365 AD with the service (there is no internal infrastructure or AD environment apart from my personal lab...)


I thought I cracked this problem by reading other posts - and that I'd selected the wrong region. But I've determined that wasn't the source of the problem. Then I thought it was something to do with our type of AD on Azure - it wasn't the "Premium" version, but just the basic AD that you get with O365 subscription. However, that hasn't 'fixed' the issue. 


It seems clearly that I need some kind of network to allow the desktops to connect with AD Azure, but it's not clear how that network is established, there isn't anything that corresponds to an Azure AD network when I run thru the wizards. 


Any thoughts about where I'm going wrong?


Exact error is:


Deployment template validation failed: 'The provided value 'Microsoft.WindowsAzure.ResourceStack.Frontdoor.Common.Entities.TemplateGenericProperty`1[Newtonsoft.Json.Linq.JToken]' for the template parameter 'newOrExistingVnet' at line '152' and column '24' is not valid. The parameter value is not part of the allowed value(s): 'existing'.'.

2 Replies
I have the exact same problem as well. I have tried multiple different configurations as checked if my settings were correct but all lead to this specific error or some other obscure errors.
Hey, This is pretty easy to resolve if you are still running into this problem. The problem comes in if you created the Network and Subnet in the same browser session that you plan to use to create the Windows Virtual Desktop pool. Open a browser Incognito and attempt to create the WVD. You should see success. You'll know you'll get success if you can finally see and select the network and subnet you was the WVD to connect to.

This is what solve my exact same issue.