WVD Login Issue: "It looks like your system administrator hasn’t set up any resources for.."

Copper Contributor


I've seen others have this issue but not sure fix. I've got 1 WVD host pool configured with 1 VM and have users assigned. Under Application Group assignments I have a few user assigned. 

When I log in via https://rdweb.wvd.microsoft.com/arm/webclient/index.html or the client, I get the same error.


"It looks like your system administrator hasn’t set up any any resources for user@azureaddomain.onmicrosoft.com yet. Please choose a different account or try again. If you believe you have received this message in error, please contact your system administrator."

I've checked a few previous posts but can't nail down where my issue is. 

Thanks for any help!

5 Replies
Could be a few things.

Have you definitely assigned a ‘Workspace’ against your application group?

@Stewart McLaughlan that was it, thanks very much for pointing out. I missed that during the setup and didn't think to setup. I'm using AD DS for my VM's to authenticate so after logging into WVD, I get the Windows domain prompt for password. I don't suspect there is a way around this? Any idea if plans to address? Nothing jumped out at me on roadmap... thanks again!

@chrismessier For now there isn't. ADFS support and SSO is coming, sometime in 2021. The end goal is native Azure AD authentication, so you just authenticate once and that's it, without having to use any SSO workarounds :) 

Since this is the top result for a web search for this error, I'm leaving this tidbit for any future support people looking at this that validated the user's resource access is good...


For users hitting WVD with web client, this same error can also occur when hitting the wrong URL. The users I have seen get the error are hitting,




Have the users try hitting the /arm/ path url to resolve their issue.