WVD Client not working on specific computer, but works on other PC´s and Web client

Copper Contributor

Hello as the subject describes a user has problems with connecting to WVD from the Remote Client on a specific computer. 

Ive tried: 
Updating Remote Client
Reinstalling Remote Client
Nothing works, but it's working on the Web Client so luckily there's a temporary workaround. 

The odd thing is that it complains over the login credentials. 
Ive tried reseting the users password, still no success. 

Any advice? 

9 Replies
There can be some strange issues with MFA. Is MFA enabled? Is the AVD setup using Azure AD only or hybrid?

Hello Tim, no theres no MFA on this user account. Aswell as no hybrib solution, just Azure AD. 

OK there are some issues with Azure AD too. Is the PC connected to Azure AD? I believe it needs to be either Azure AD joined or at least connected to an Azure AD account (Accounts - Add a workplace or school account).
Have you had the user try the client on a different machine to rule out that machine itself? If it works in the web then everything else is clearly fine.
Since it works using the HTML5 client it seems to be an avd client related issue.
Maybe try this script from Micha Wets to uninstall the complete installation and install it again.
This is her private computer, might not be Azure AD joined, ill check :)
Ye its works on other computers, so seems to be machine related.
Documented here:


"If you see the following error message when you initiate a remote desktop connection to your VM: Your credentials did not work.
Verify that the Windows 10 PC you are using to initiate the remote desktop connection is one that is either Azure AD joined, or hybrid Azure AD joined to the same Azure AD directory where your VM is joined to."

Note this only applies to pure Azure AD deployments, not when hybrid AD is used.