Windows Virtual Desktop - The Hostpool shows an incorrect Name.


I created two hostpools  like hostpoolA and HostpoolB with PowerShell, but when both the hostpools' name are "Session Desktop" in the Remote Desktop. 

By the way, I can add users  to the HostpoolA and HostpoolB with powershell, and it worked well.

What is the problem? 

5 Replies

@null null : If I understand your problem you want to name the session host pools the same? This is not supported. The host pool name as well as app groups need to be unique within a tenant. Looks like we are missing documentation on that. 


Thank you for highlighting.  

@Eva Seydl  

I am sorry I didn’t explain my question very clearly.

What I want to say is the host pool name shows in the remote desktop client (Session Desktop) is different from the name I wrote in Azure Portal (like hostpooltest00).

For example, I created three host pools and signed the user to them.

But when I open the WVD remote desktop client, there are three PC logos with the same name as “Session Desktop” inside of the host pool name I created like HostpoolA, HostpoolB, HostpoolC.


best response confirmed by Eva Seydl (Microsoft)

@null null : thank you for clarification. The host pool itself is not reflected in the client application. It is more of a management concept.


For renaming the default name run this PowerShell Cmdlet:

Set-RdsRemoteDesktop -TenantName $tenant -HostPoolName $Hostpool -AppGroupName "Desktop Application Group" -FriendlyName "win10origsso"

@Eva Seydl 

Thanks so much. 

Came across this thread with the same problem.  In my case I did have a friendly name to the pool.  Only difference is I had created the pool and assigned the friendly name via the GUI (


Powershell confirmed the friendly name was there so I was stumped.  Decided to repeat the command via the Powershell to put gain the exact same friendly name and it worked.  Looks like a bug to me in the GUI.