Windows Server 2019 Webclient, cannot install certificate anymore

New Contributor

I try to set up the webclient like described in 
Set up the Remote Desktop web client for your users | Microsoft Docs

When running the command Import-RDWebClientBrokerCert, it fails with the following error:

PS C:\> Import-RDWebClientBrokerCert .\demo.cer
New-Object : Exception calling ".ctor" with "1" argument(s): "The system cannot find the file specified.
At C:\Program Files\WindowsPowerShell\Modules\RDWebClientManagement\1.0.3\RDWebClientManagement.psm1:1116 char:13
+     $cert = New-Object System.Security.Cryptography.X509Certificates. ...
+             ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidOperation: (:) [New-Object], MethodInvocationException
    + FullyQualifiedErrorId : ConstructorInvokedThrowException,Microsoft.PowerShell.Commands.NewObjectCommand


This all worked before, I had it all up and running for a year, I just had to install a new certificate.

I even tried in on a completely new and fresh Server 2019 which I set up as a RDS Gateway server.


I have not found anything pointing me in the right direction. Any hints?


0 Replies