Version 1.2.675 of the Windows client (MSRDC) released to all users!


We released the February update (version 1.2.675) of the Windows Desktop client to all users earlier today.


Here's What's new in this release:

  • Connections to Windows Virtual Desktop are now blocked if the RDP file is missing the signature or one of the signscope properties has been modified.
  • When a Workspace is empty or has been removed, the Connection Center no longer appears to be empty.
  • Added the activity ID and error code on disconnect messages to improve troubleshooting. You can copy the dialog message with Ctrl+C.
  • Fixed an issue that caused the desktop connection settings to not detect displays.
  • Client updates no longer automatically restart the PC.
  • Windowless icons should no longer appear on the taskbar.
26 Replies

@David Belanger  Hi David, we have 5-6 users using WVD client in Windows 7 SP1. Until today morning they are doing good. But in the morning the users are not able to login to the WVD and the client is asking for an update. We updated the WVD clients, and we are facing an error. Please check the screenshot for more information. The same users are able to login to WVD using a web URL from Windows 7 SP1. What might be the issue? is there any way to troubleshoot this? Please give me some leads on this.



We face the same issue with this version.

It works with the web client though. Any luck already?

Hey, Martijn we still have the issue. I raised a support ticket and I'm in contact with 
David Belanger from Microsoft I will update you if anything works ours. We are able to login with the web client but not with the WVD client. Do you have the same login issue in your environment?
 @Martijn Devolder 



Yes I have the exact same problem, but so far only on my computer. When I test it on another computer in the domain it works. The web client works indeed.

what is your computer configuration and what is the computer configuration in the domain? Clarify me, you mean to say it's not working with WVD client but works with web URL in the computer which is a domain joined? @Martijn Devolder 



My device is actually not domain joined. But my account is listed in 'Work or school' account

I noticed in the lastest version of the client it asks to allow the organisation to manage my device.


I tried everything here.


- Allow

- Don't allow

- Only this app


So it must be some setting on my device that's causing this, but I did not find it yet.


And yes indeed I have absolutely no issues with the web client. Only with the locally installed WVD client.

@Martijn Devolder We are still investigating this issue. Just to make sure. In your environment, you have multiple users who updated to version 1.2.675 on Windows 7 and most users have no issues except for your device which can't connect. Is that correct?

@David Belanger 

Yes my device is for now the only one out of 3 tested.

It's not Windows 7 though. I'm working on Windows 10.

@Martijn Devolder 

We have exact the same issues since 29/03.

Start with one PC, but more and more users comes to me with this issue.

Is there an update about this problem?


Hi David we went ahead and raised a support ticket with Microsoft Team. We have a remote session and did some troubleshooting. The support team checked if the connection is established via client and web URL. Via client its not established. So, they went ahead and re created the scenario and its working with Windows 7 Enterprise. Support Team asked re create the scenario with windows 7 Professional SP1. I am looking for the ISO. @David Belanger 

Sorry to add a "Me Too" to this thread: This update has broken Remote Desktop for our Windows 7 users.

@David Belanger : Is there a place we can go to download old versions of Remote Desktop?

@FortyMegabytes You can access some of the previous versions of the client at the following location:


What version were you upgrading from?


Can you see if uninstalling version 675 and re-installing the previous version works?



None of these versions work anymore for me

@Martijn Devolder Just to confirm, once you get in the bad state, even uninstalling and re-installing the a previous version of the client (one that worked before) doesn't solve the problem and you are still blocked?

@David Belanger So, interestingly, uninstalling the new Remote Desktop client and installing the old version did *not* fix the issue.  Our Windows 7 clients still cannot access WVD.


Since everyone in our organization is supposed to be on Windows 10 anyway, we've been using this as leverage to force the stragglers to update their laptops.  So this isn't hugely impacting for us.


Still, I'm puzzled why Remote Desktop would stop working even after uninstalling the new version and reinstalling the previously-working version.  My guess is a registry change that's not being reverted by an uninstall.

@FortyMegabytes / @Martijn Devolder / @karoto Are you folks still seeing this issue with version 790 released last week? If so, we'll likely need you to collect additional traces to help us investigate. Let me know if you want to help with that.

Hello, it worked for 1 day. Next time I started the client it asked to install the update. So I did... The problem returned.

I have been in contact with Abu since. There seems to be no error log creation when this error occurs.