Validation failed upon creating the host pool

Occasional Contributor

Hi guys,


Previous week I tried to deploy my first Windows Virtual Desktop pool but it did not succeed because of VM's not joining the domain. 

This week I tried the same thing again but i'm getting an error already this time when validating the host pool.


Error below:

Deployment template validation failed: 'The template resource '_artifactsLocation' at line '109' and column '31' is not valid: The language expression property 'templateLink' doesn't exist, available properties are 'template, templateHash, parameters, mode, debugSetting, provisioningState'.. Please see for usage details.'.


The setup I'm using to get this working is:

  • AADDS synced with Azure AD
  • Virtual Network with 2 subnets
    • 1 subnet for AADDS
    • 1 subnet for the virtual machines


I really can't think how this error would come up. I literally didn't change anything to my setup from the week before. Do you guys have any idea?


Thanks in advance.


2 Replies
best response confirmed by Eva Seydl (Microsoft)

@Luis_Farinango: We have a known issue which we are currently resolving. Communication went out to impacted subscriptions through Azure Service Health - learn more how to set it up here.


Use the following approaches to succeed with your deployment.


Work around #1
Deploy VMs using any of the methods Azure support (ARM, portal, APIs, PowerShell, Terraforms)
Perform domain join of created VMs via following arm template
Create WVD host pool and registration token via PowerShell
Run following ARM template to perform registration

Work around #2
All steps form work around #1 can be performed manually

@Eva Seydl 

Thank you for the reply.

I used workaround #1 en this solution worked perfectly! Finally I can begin with testing :)