Update-AzWvdSessionHost Command error

Occasional Visitor

When I run the below command I get the corresponding error.  This is using the Spring 2020 preview commands too.  What I am trying to do is directly assign a user to a session host, per the documentation this should work.  Anyone else get this error?


Update-AzWvdSessionHost -HostPoolName MyVirtuaDesktop -Name VM2.domain.com -ResourceGroupName MyResourceGroup -AssignedUser myupn@domain.com




Update-AzWvdSessionHost : The server responded with a Server Error, Status: InternalServerError
At line:1 char:1
+ Update-AzWvdSessionHost -HostPoolName MyVirtualDesktop -Name VM2.domain.com ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidOperation: ({ SubscriptionI...sionHostPatch }:<>f__AnonymousType24`5) [Update-AzWvdSessionHost_UpdateExpanded], RestException`1
+ FullyQualifiedErrorId : Microsoft.Azure.PowerShell.Cmdlets.DesktopVirtualization.Cmdlets.UpdateAzWvdSessionHost_UpdateExpanded



3 Replies

@dbachechi Did you try encapsulating the strings within quotes? Update-AzWvdSessionHost -HostPoolName MyVirtuaDesktop -Name "VM2.domain.com" -ResourceGroupName MyResourceGroup -AssignedUser "myupn@domain.com"



Did you resolve this issue?


I have the same problem, tried removing, rebuilding, adding licences, adding permissions and roles etc but nothing seems to solve the problem. Using the Web or Powershell gives same error with no clues...


Update-AzWvdSessionHost_UpdateExpanded: The server responded with a Server Error, Status: InternalServerError


Commands in quotes doesn't help


Everything seems correct, VMs joined to domain, AD connect setup and working, O365 licences installed, Owner permissions correct, DNS correct. Can login to VM locally as user, just cannot assign any user to any VM for remote access, "Internal Server Error" isn't really helping.





(internal server error spring update 2020)


I have opened a support request with Microsoft support, we rebuilt the WVD and got the same errors, looks like a bug and now waiting for support to resolve :facepalm: