Unable to login to the new RDWEB Webclient

Copper Contributor



I am using the newest version of the RD Webclient It works just fine from internal, but when i login using it from remote i keep getting this error: 

"Sign in failed. Please check your user name and password and try again"


The password is correct and works just fine when i am inside the network. I have also tried with a domain admin, and also checked the my RD Farm is using a "per user" licensing.


I cannot see anything in the event-logs on the server hosting this RDWeb webclient.


I have tried uninstall, reinstall and updating the webclient using this article - but same error.
Set up the Remote Desktop web client for your users


See screenshot below


Any suggestions or help are very welcome





2 Replies

@JesperHansen : When you looked at the logs on the RD Web machine, were you also to look up IIS logs? IIS is what makes the logon requests, to may have Success/Errors.


Otherwise, I think the best step to understand and fix this is going to be through creating a support case.

@JesperHansen - If you weren't able to find out how to resolve this my recommendation would be to:

1. Open Task Manager

2. Navigate to the details tab

3. search for a proccess called wksprt.exe

4. End the task and retry


Hope it helps some folks with the same issue.