Unable to deploy window host for azure wvd

Occasional Contributor

Hi have prepared window-7 master image for wvd and deployed but getting the error message.

 

Error Message:

 

statusMessage": "{\"status\":\"Failed\",\"error\":{\"code\":\"ResourceOperationFailure\",\"message\":\"The resource operation completed with terminal provisioning state 'Failed'.\",\"details\":[{\"code\":\"VMExtensionProvisioningError\",\"message\":\"VM has reported a failure when processing extension 'dscextension'. Error message: \\\"DSC Configuration 'AddSessionHost' completed with error(s). Following are the first few: PowerShell DSC resource MSFT_ScriptResource failed to execute Set-TargetResource functionality with error message: Cannot process argument transformation on parameter 'rdshIs1809OrLater'. Cannot convert value \\\"\\\" to type \\\"System.Boolean\\\". Boolean parameters accept only Boolean values and numbers, such as $True, $False, 1 or 0. The SendConfigurationApply function did not succeed.\\\"\\r\\n\\r\\nMore information on troubleshooting is available at https://aka.ms/VMExtensionDSCWindowsTroubleshoot \"}]}}"

5 Replies

@Pradeep MISHRA see https://docs.microsoft.com/en-us/azure/virtual-desktop/virtual-desktop-fall-2019/deploy-windows-7-vi...

Also works for Windows Virtual Desktop Spring Update.

 

Deployment by Windows Virtual Desktop | Host pools is not possible because a different agent is used during the deployment.

@mkolb,

 

Thanks for support.

 

I have follow this article but still hot session unable to added in host pool.

 

Can you help to add session host in hostpool.

If the Windows 7 Enterprise VM is not visible in the WVD Portal, verfiy eventvwr and whether there is a communication -> https://docs.microsoft.com/en-us/azure/virtual-desktop/overview#requirements

I can only say that the article worked for me with a Windows 7 Enterprise Image from the gallery.

@mkolb,

 

Issue is still not resolved and support team is also working on this case (case id 120052324000236 ) last 5 days but no update

@Pradeep MISHRA Did you get this resolved?  I also have a case open for the same issue.  Seems to only happen with Server 2012R2 OS. Case#120061721003983